aboutsummaryrefslogtreecommitdiff
path: root/devel/phpunit9/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/phpunit9/Makefile')
-rw-r--r--devel/phpunit9/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/phpunit9/Makefile b/devel/phpunit9/Makefile
new file mode 100644
index 000000000000..066eb85d6088
--- /dev/null
+++ b/devel/phpunit9/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= phpunit
+PORTVERSION= 9.5.8
+CATEGORIES= devel www
+MASTER_SITES= https://phar.phpunit.de/
+PKGNAMESUFFIX= 9${PHP_PKGNAMESUFFIX}
+EXTRACT_SUFX= .phar
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Testing framework for unit tests
+
+LICENSE= BSD3CLAUSE
+
+USES= cpe php:flavors
+USE_PHP= dom json pcre phar spl
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/phpunit
+
+CONFLICTS_INSTALL= phpunit6 phpunit7 phpunit8
+
+CPE_VENDOR= phpunit_project
+
+do-extract:
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}/phpunit
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/phpunit ${STAGEDIR}${PREFIX}/bin/phpunit
+
+.include <bsd.port.mk>