aboutsummaryrefslogtreecommitdiff
path: root/devel/plasma5-plasma-sdk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/plasma5-plasma-sdk/Makefile')
-rw-r--r--devel/plasma5-plasma-sdk/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/devel/plasma5-plasma-sdk/Makefile b/devel/plasma5-plasma-sdk/Makefile
index ebc49ff32dc2..ae4a10fc9989 100644
--- a/devel/plasma5-plasma-sdk/Makefile
+++ b/devel/plasma5-plasma-sdk/Makefile
@@ -1,18 +1,20 @@
PORTNAME= plasma-sdk
-DISTVERSION= ${KDE_PLASMA_VERSION}
+DISTVERSION= ${KDE_PLASMA_VERSION}.1
CATEGORIES= devel kde kde-plasma
MAINTAINER= kde@FreeBSD.org
COMMENT= Plasma5 applications useful for Plasma development
+WWW= https://www.kde.org/plasma-desktop
-USES= cmake compiler:c++11-lib cpe gettext kde:5 qt:5 tar:xz
-USE_KDE= archive attica auth codecs completion config configwidgets \
- coreaddons dbusaddons ecm i18n iconthemes itemmodels \
- jobwidgets kdeclarative kio kirigami2 newstuff package parts \
- plasma-framework service sonnet texteditor textwidgets \
- widgetsaddons windowsystem xmlgui \
- doctools_build
-USE_QT= concurrent core dbus declarative gui network webkit widgets x11extras xml \
- buildtools_build qmake_build
+USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz xorg
+USE_KDE= archive auth codecs completion config configwidgets coreaddons \
+ dbusaddons i18n iconthemes jobwidgets kdeclarative kio package \
+ parts plasma-framework service solid sonnet syntaxhighlighting \
+ texteditor textwidgets widgetsaddons windowsystem xmlgui \
+ doctools:build ecm:build \
+ kirigami2:run
+USE_QT= concurrent core dbus declarative gui network svg widgets xml \
+ buildtools:build qmake:build
+USE_XORG= x11
.include <bsd.port.mk>