aboutsummaryrefslogtreecommitdiff
path: root/devel/py-arrow/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-arrow/Makefile')
-rw-r--r--devel/py-arrow/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/devel/py-arrow/Makefile b/devel/py-arrow/Makefile
index 71c57fa50254..b06f6695fb90 100644
--- a/devel/py-arrow/Makefile
+++ b/devel/py-arrow/Makefile
@@ -1,7 +1,7 @@
# Created by: Grzegorz Blach <gblach@FreeBSD.org>
PORTNAME= arrow
-PORTVERSION= 0.17.0
+PORTVERSION= 1.1.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,4 +18,10 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3800
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extensions@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>