aboutsummaryrefslogtreecommitdiff
path: root/devel/py-dm-tree/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-dm-tree/Makefile')
-rw-r--r--devel/py-dm-tree/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/py-dm-tree/Makefile b/devel/py-dm-tree/Makefile
new file mode 100644
index 000000000000..137635994a01
--- /dev/null
+++ b/devel/py-dm-tree/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= dm-tree
+DISTVERSION= 0.1.8
+CATEGORIES= devel
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for working with nested data structures
+WWW= https://tree.readthedocs.io/en/latest/
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= cmake:devel/cmake-core \
+ pybind11>0:devel/pybind11
+LIB_DEPENDS= libabsl_strings.so:devel/abseil
+
+USES= localbase python
+USE_PYTHON= distutils concurrent
+
+MAKE_ENV= FREEBSD_LOCALBASE=${LOCALBASE}
+
+.include <bsd.port.mk>