aboutsummaryrefslogtreecommitdiff
path: root/devel/py-fsspec/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-fsspec/Makefile')
-rw-r--r--devel/py-fsspec/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/devel/py-fsspec/Makefile b/devel/py-fsspec/Makefile
index 974ba9e66419..5989e2040b8c 100644
--- a/devel/py-fsspec/Makefile
+++ b/devel/py-fsspec/Makefile
@@ -1,26 +1,28 @@
-# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-
PORTNAME= fsspec
-PORTVERSION= 2021.7.0
+PORTVERSION= 2024.3.1
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= File-system specification
+WWW= https://filesystem-spec.readthedocs.io/en/latest/ \
+ https://github.com/fsspec/filesystem_spec
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= GITHUB
+GITHUB_DESC= GitHub file system
-.if ${PYTHON_REL} < 30800
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0:devel/py-importlib-metadata@${PY_FLAVOR}
-.endif
+GITHUB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>