aboutsummaryrefslogtreecommitdiff
path: root/devel/py-gast/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-gast/Makefile')
-rw-r--r--devel/py-gast/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/devel/py-gast/Makefile b/devel/py-gast/Makefile
index e0b5191bca72..78619456d236 100644
--- a/devel/py-gast/Makefile
+++ b/devel/py-gast/Makefile
@@ -1,23 +1,23 @@
PORTNAME= gast
-PORTVERSION= 0.5.1
+PORTVERSION= 0.5.4
+PORTREVISION= 1
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= AST that abstracts the underlying Python version
+WWW= https://github.com/serge-sans-paille/gast
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astunparse>=0:devel/py-astunparse@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
-USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+USES= python
+USE_PYTHON= autoplist concurrent pep517 unittest
NO_ARCH= yes
-do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} -m unittest -v
-
.include <bsd.port.mk>