aboutsummaryrefslogtreecommitdiff
path: root/devel/py-gitpython/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-gitpython/Makefile')
-rw-r--r--devel/py-gitpython/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/devel/py-gitpython/Makefile b/devel/py-gitpython/Makefile
index 02905cdaf7f1..828400e9b7bd 100644
--- a/devel/py-gitpython/Makefile
+++ b/devel/py-gitpython/Makefile
@@ -1,26 +1,27 @@
PORTNAME= gitpython
-DISTVERSION= 3.1.20
+DISTVERSION= 3.1.30
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= GitPython-${PORTVERSION}
MAINTAINER= ygy@FreeBSD.org
COMMENT= Python Git Library
+WWW= https://github.com/gitpython-developers/GitPython
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ddt>=1.1.1:devel/py-ddt@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}gitdb>=4.0.1:devel/py-gitdb@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.7.4.3:devel/py-typing-extensions@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gitdb>=4.0.1<5:devel/py-gitdb@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ddt>=1.1.1:devel/py-ddt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR}
-NO_ARCH= yes
USES= python
USE_PYTHON= autoplist concurrent distutils
+NO_ARCH= yes
+
do-test:
cd ${WRKSRC} && ${PYTHON_CMD} -m nose