aboutsummaryrefslogtreecommitdiff
path: root/devel/py-hacking/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-hacking/Makefile')
-rw-r--r--devel/py-hacking/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/py-hacking/Makefile b/devel/py-hacking/Makefile
new file mode 100644
index 000000000000..7ef6fc6b2904
--- /dev/null
+++ b/devel/py-hacking/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= hacking
+PORTVERSION= 6.1.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= OpenStack Hacking Guideline Enforcement
+WWW= https://docs.openstack.org/hacking/latest/ \
+ https://github.com/openstack/hacking
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=2.0.0:devel/py-pbr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flake8>=6.1.0<6.2:devel/py-flake8@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>