aboutsummaryrefslogtreecommitdiff
path: root/devel/py-hatchling/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-hatchling/Makefile')
-rw-r--r--devel/py-hatchling/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/devel/py-hatchling/Makefile b/devel/py-hatchling/Makefile
index f237164f593d..a720dbdf82dc 100644
--- a/devel/py-hatchling/Makefile
+++ b/devel/py-hatchling/Makefile
@@ -1,5 +1,6 @@
PORTNAME= hatchling
PORTVERSION= 1.12.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,13 +12,14 @@ WWW= https://github.com/pypa/hatch/tree/master/backend
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}editables>=0.3:devel/py-editables@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=21.3:devel/py-packaging@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pathspec>=0.10.1:devel/py-pathspec@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pluggy>=1.0.0:devel/py-pluggy@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
@@ -31,8 +33,4 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0:devel/py-importlib-me
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tomli>=1.2.2:textproc/py-tomli@${PY_FLAVOR}
.endif
-post-patch:
- @${RM} ${WRKSRC}/pyproject.toml
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.post.mk>