aboutsummaryrefslogtreecommitdiff
path: root/devel/py-hidraw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-hidraw/Makefile')
-rw-r--r--devel/py-hidraw/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/py-hidraw/Makefile b/devel/py-hidraw/Makefile
new file mode 100644
index 000000000000..cf47df05ee64
--- /dev/null
+++ b/devel/py-hidraw/Makefile
@@ -0,0 +1,28 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= hidraw
+PORTVERSION= 0.2.1
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Python interface to gather hidraw information
+
+LICENSE= BSD2CLAUSE
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= daym
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1300000
+IGNORE= requires FreeBSD 13 or later with hidraw support
+.endif
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/hidraw/_hidraw.so
+
+.include <bsd.port.post.mk>