aboutsummaryrefslogtreecommitdiff
path: root/devel/py-installer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-installer/Makefile')
-rw-r--r--devel/py-installer/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/py-installer/Makefile b/devel/py-installer/Makefile
new file mode 100644
index 000000000000..41d3a06c8947
--- /dev/null
+++ b/devel/py-installer/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= installer
+PORTVERSION= 0.2.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Library for installing Python wheels
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 30700
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>=0:devel/py-importlib-resources@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>