aboutsummaryrefslogtreecommitdiff
path: root/devel/py-isoduration/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-isoduration/Makefile')
-rw-r--r--devel/py-isoduration/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/devel/py-isoduration/Makefile b/devel/py-isoduration/Makefile
new file mode 100644
index 000000000000..f8144ce71f4f
--- /dev/null
+++ b/devel/py-isoduration/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= isoduration
+PORTVERSION= 20.11.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Operations with ISO 8601 durations
+WWW= https://github.com/bolsote/isoduration
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}arrow>=0.15.0:devel/py-arrow@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>