aboutsummaryrefslogtreecommitdiff
path: root/devel/py-optree/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-optree/Makefile')
-rw-r--r--devel/py-optree/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/py-optree/Makefile b/devel/py-optree/Makefile
new file mode 100644
index 000000000000..6a480a634f0d
--- /dev/null
+++ b/devel/py-optree/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= optree
+PORTVERSION= 0.11.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Optimized PyTree utilities
+WWW= https://optree.readthedocs.io/en/latest/ \
+ https://github.com/metaopt/optree
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= cmake:devel/cmake-core \
+ ${PYTHON_PKGNAMEPREFIX}pybind11>=0:devel/py-pybind11@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4.0.0:devel/py-typing-extensions@${PY_FLAVOR}
+
+USES= compiler:c++20-lang python
+USE_PYTHON= autoplist concurrent pep517
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>