aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pydantic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-pydantic/Makefile')
-rw-r--r--devel/py-pydantic/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/py-pydantic/Makefile b/devel/py-pydantic/Makefile
index ec00378b359d..d08d8bbb6128 100644
--- a/devel/py-pydantic/Makefile
+++ b/devel/py-pydantic/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pydantic
-DISTVERSION= 1.9.1
+DISTVERSION= 1.10.2
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,8 +14,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.7.4.3:devel/py-typing-extensions@${PY_FLAVOR}
USES= cpe python:3.7+
-USE_PYTHON= distutils cython autoplist
+USE_PYTHON= distutils cython autoplist pytest # tests fail to run, see https://github.com/pydantic/pydantic/issues/4535
CPE_VENDOR= pydantic_project
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/pydantic/*${PYTHON_EXT_SUFFIX}.so
+
.include <bsd.port.mk>