aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pyicu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-pyicu/Makefile')
-rw-r--r--devel/py-pyicu/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/py-pyicu/Makefile b/devel/py-pyicu/Makefile
new file mode 100644
index 000000000000..640f0944a3a2
--- /dev/null
+++ b/devel/py-pyicu/Makefile
@@ -0,0 +1,27 @@
+# Created by: bland@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= pyicu
+PORTVERSION= 1.8
+PORTREVISION= 2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyICU-${PORTVERSION}
+
+MAINTAINER= bland@FreeBSD.org
+COMMENT= Python extension wrapping IBM's ICU C++ API
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+MAKE_ENV+= PYICU_INCLUDES="${PREFIX}/include" \
+ PYICU_CFLAGS="-w:-DPYICU_VER=\"${PORTVERSION}\"" \
+ PYICU_LFLAGS="-L${PREFIX}/lib"
+
+LIB_DEPENDS+= libicudata.so:${PORTSDIR}/devel/icu
+
+.include <bsd.port.mk>