aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pyquery/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-pyquery/Makefile')
-rw-r--r--devel/py-pyquery/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/py-pyquery/Makefile b/devel/py-pyquery/Makefile
new file mode 100644
index 000000000000..e748c923afd3
--- /dev/null
+++ b/devel/py-pyquery/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pyquery
+PORTVERSION= 1.4.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= jQuery-like library for Python
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cssselect>=0.7.0:www/py-cssselect@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=2.1:devel/py-lxml@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>