aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pytest-timeout/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-pytest-timeout/Makefile')
-rw-r--r--devel/py-pytest-timeout/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/devel/py-pytest-timeout/Makefile b/devel/py-pytest-timeout/Makefile
index 78210b4bb89c..5ffcb3859d19 100644
--- a/devel/py-pytest-timeout/Makefile
+++ b/devel/py-pytest-timeout/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pytest-timeout
-PORTVERSION= 1.4.2
+PORTVERSION= 2.1.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,18 +10,15 @@ COMMENT= Pytest plugin to abort hanging tests
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.6.0:devel/py-pytest@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.6.0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=5.0.0:devel/py-pytest@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pexpect>0:misc/py-pexpect@${PY_FLAVOR}
USES= python:3.6+
-USE_PYTHON= autoplist distutils
-
-NO_ARCH= yes
+USE_PYTHON= autoplist distutils pytest
TEST_ENV+= PYTHONPATH=${TEST_WRKSRC}
-do-test:
- @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest)
+
+NO_ARCH= yes
.include <bsd.port.mk>