aboutsummaryrefslogtreecommitdiff
path: root/devel/py-python-rapidjson/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-python-rapidjson/Makefile')
-rw-r--r--devel/py-python-rapidjson/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/py-python-rapidjson/Makefile b/devel/py-python-rapidjson/Makefile
new file mode 100644
index 000000000000..4f745c6d237e
--- /dev/null
+++ b/devel/py-python-rapidjson/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= python-rapidjson
+DISTVERSION= 1.6
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python wrapper around rapidjson
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+do-test: install # tests fail: https://github.com/python-rapidjson/python-rapidjson/issues/163
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+
+.include <bsd.port.mk>