aboutsummaryrefslogtreecommitdiff
path: root/devel/py-virtualenvwrapper/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-virtualenvwrapper/Makefile')
-rw-r--r--devel/py-virtualenvwrapper/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/devel/py-virtualenvwrapper/Makefile b/devel/py-virtualenvwrapper/Makefile
index e9b26a5added..6b40f376034d 100644
--- a/devel/py-virtualenvwrapper/Makefile
+++ b/devel/py-virtualenvwrapper/Makefile
@@ -13,17 +13,17 @@ COMMENT= Set of extensions to virtualenv
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>0:devel/py-pbr
-RUN_DEPENDS= ${PKGNAMEPREFIX}stevedore>0:devel/py-stevedore \
- ${PKGNAMEPREFIX}virtualenv>0:devel/py-virtualenv \
- ${PKGNAMEPREFIX}virtualenv-clone>0:devel/py-virtualenv-clone
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>0:devel/py-pbr@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stevedore>0:devel/py-stevedore@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}virtualenv>0:devel/py-virtualenv@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}virtualenv-clone>0:devel/py-virtualenv-clone@${FLAVOR}
OPTIONS_DEFINE= DOCS
-DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx \
- ${PYTHON_PKGNAMEPREFIX}sphinxcontrib-bitbucket>=1.0:textproc/py-sphinxcontrib-bitbucket
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinxcontrib-bitbucket>=1.0:textproc/py-sphinxcontrib-bitbucket@${FLAVOR}
-USES= python
+USES= python:2.7
USE_PYTHON= autoplist concurrent distutils
DOCS_VARS= DOCSDIR=${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME} \