aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-prometheus-client-mmap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rubygem-prometheus-client-mmap/Makefile')
-rw-r--r--devel/rubygem-prometheus-client-mmap/Makefile28
1 files changed, 18 insertions, 10 deletions
diff --git a/devel/rubygem-prometheus-client-mmap/Makefile b/devel/rubygem-prometheus-client-mmap/Makefile
index 0e9bb128997b..91688b4f3585 100644
--- a/devel/rubygem-prometheus-client-mmap/Makefile
+++ b/devel/rubygem-prometheus-client-mmap/Makefile
@@ -1,5 +1,5 @@
PORTNAME= prometheus-client-mmap
-DISTVERSION= 0.28.1
+PORTVERSION= 1.0.2
CATEGORIES= devel rubygems
MASTER_SITES= RG
@@ -11,20 +11,28 @@ LICENSE= APACHE20
RUN_DEPENDS= rubygem-rb_sys>=0.9<1:lang/rubygem-rb_sys
-USES= gem
-# needs to be migrated to rust
-#USES= cargo gem
-#GEMFILES= ${GEM_NAME}${EXTRACT_SUFX}
-#CARGO_CARGOTOML= ${WRKSRC}/ext/fast_mmaped_file_rs/Cargo.toml
-#CARGO_CARGOLOCK= ${WRKSRC}/ext/fast_mmaped_file_rs/Cargo.lock
+USES= cargo gem gmake llvm:build
-# Generate with: make cargo-crates
-# 85dd
+# Required to be able to build the rust library the port uses
+GEMFILES:= ${DISTNAME}${GEM_EXT}
+CARGO_VENDOR_DIR= ${WRKSRC}/ext/fast_mmaped_file_rs/cargo-crates
+CARGO_CARGOTOML= ${WRKSRC}/ext/fast_mmaped_file_rs/Cargo.toml
+CARGO_CARGOLOCK= ${WRKSRC}/ext/fast_mmaped_file_rs/Cargo.lock
+CARGO_BUILD= no
+CARGO_INSTALL= no
+GEM_ENV+= MAKE=gmake
+
+# update the crates file with: make cargo-crates > Makefile.crates
+
+# The port installs files writeable
+# Is reported upstream: https://gitlab.com/gitlab-org/ruby/gems/prometheus-client-mmap/-/issues/60
+post-extract:
+ ${CHMOD} -R o-w ${WRKSRC}
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
-CONFIGURE_ARGS+= --with-cflags="-Wno-error=incompatible-function-pointer-types"
+RUBYGEM_ARGS+= --with-cflags="-Wno-error=incompatible-function-pointer-types"
.endif
.include <bsd.port.mk>