aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/got/Makefile1
-rw-r--r--devel/got/files/openbsd-compat/Makefile4
-rw-r--r--devel/got/files/openbsd-compat/basename.c63
-rw-r--r--devel/got/files/openbsd-compat/dirname.c69
-rw-r--r--devel/got/files/openbsd-compat/libgen.h10
5 files changed, 146 insertions, 1 deletions
diff --git a/devel/got/Makefile b/devel/got/Makefile
index 5b027407558c..016a62eb992f 100644
--- a/devel/got/Makefile
+++ b/devel/got/Makefile
@@ -2,6 +2,7 @@
PORTNAME= got
PORTVERSION= 0.39
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://gameoftrees.org/releases/
diff --git a/devel/got/files/openbsd-compat/Makefile b/devel/got/files/openbsd-compat/Makefile
index c590b173a81a..d02773ebfb77 100644
--- a/devel/got/files/openbsd-compat/Makefile
+++ b/devel/got/files/openbsd-compat/Makefile
@@ -1,7 +1,9 @@
LIB= openbsd-compat
INTERNALLIB=
-SRCS= freezero.c \
+SRCS= basename.c \
+ dirname.c \
+ freezero.c \
getdtablecount.c \
imsg.c \
imsg-buffer.c \
diff --git a/devel/got/files/openbsd-compat/basename.c b/devel/got/files/openbsd-compat/basename.c
new file mode 100644
index 000000000000..2081cb95a28b
--- /dev/null
+++ b/devel/got/files/openbsd-compat/basename.c
@@ -0,0 +1,63 @@
+/* $OpenBSD: basename.c,v 1.16 2019/01/25 00:19:25 millert Exp $ */
+
+/*
+ * Copyright (c) 1997, 2004 Todd C. Miller <millert@openbsd.org>
+ *
+ * Permission to use, copy, modify, and distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ */
+
+#include <errno.h>
+#include <libgen.h>
+#include <limits.h>
+#include <string.h>
+
+char *
+basename(const char *path)
+{
+ static char bname[PATH_MAX];
+ size_t len;
+ const char *endp, *startp;
+
+ /* Empty or NULL string gets treated as "." */
+ if (path == NULL || *path == '\0') {
+ bname[0] = '.';
+ bname[1] = '\0';
+ return (bname);
+ }
+
+ /* Strip any trailing slashes */
+ endp = path + strlen(path) - 1;
+ while (endp > path && *endp == '/')
+ endp--;
+
+ /* All slashes becomes "/" */
+ if (endp == path && *endp == '/') {
+ bname[0] = '/';
+ bname[1] = '\0';
+ return (bname);
+ }
+
+ /* Find the start of the base */
+ startp = endp;
+ while (startp > path && *(startp - 1) != '/')
+ startp--;
+
+ len = endp - startp + 1;
+ if (len >= sizeof(bname)) {
+ errno = ENAMETOOLONG;
+ return (NULL);
+ }
+ memcpy(bname, startp, len);
+ bname[len] = '\0';
+ return (bname);
+}
diff --git a/devel/got/files/openbsd-compat/dirname.c b/devel/got/files/openbsd-compat/dirname.c
new file mode 100644
index 000000000000..7a5d83b91e0a
--- /dev/null
+++ b/devel/got/files/openbsd-compat/dirname.c
@@ -0,0 +1,69 @@
+/* $OpenBSD: dirname.c,v 1.16 2019/01/25 00:19:25 millert Exp $ */
+
+/*
+ * Copyright (c) 1997, 2004 Todd C. Miller <millert@openbsd.org>
+ *
+ * Permission to use, copy, modify, and distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ */
+
+#include <errno.h>
+#include <libgen.h>
+#include <limits.h>
+#include <string.h>
+
+/* A slightly modified copy of this file exists in libexec/ld.so */
+
+char *
+dirname(const char *path)
+{
+ static char dname[PATH_MAX];
+ size_t len;
+ const char *endp;
+
+ /* Empty or NULL string gets treated as "." */
+ if (path == NULL || *path == '\0') {
+ dname[0] = '.';
+ dname[1] = '\0';
+ return (dname);
+ }
+
+ /* Strip any trailing slashes */
+ endp = path + strlen(path) - 1;
+ while (endp > path && *endp == '/')
+ endp--;
+
+ /* Find the start of the dir */
+ while (endp > path && *endp != '/')
+ endp--;
+
+ /* Either the dir is "/" or there are no slashes */
+ if (endp == path) {
+ dname[0] = *endp == '/' ? '/' : '.';
+ dname[1] = '\0';
+ return (dname);
+ } else {
+ /* Move forward past the separating slashes */
+ do {
+ endp--;
+ } while (endp > path && *endp == '/');
+ }
+
+ len = endp - path + 1;
+ if (len >= sizeof(dname)) {
+ errno = ENAMETOOLONG;
+ return (NULL);
+ }
+ memcpy(dname, path, len);
+ dname[len] = '\0';
+ return (dname);
+}
diff --git a/devel/got/files/openbsd-compat/libgen.h b/devel/got/files/openbsd-compat/libgen.h
new file mode 100644
index 000000000000..dbea51c5234a
--- /dev/null
+++ b/devel/got/files/openbsd-compat/libgen.h
@@ -0,0 +1,10 @@
+#ifndef _OPENBSD_COMPAT_LIBGEN_H_
+#define _OPENBSD_COMPAT_LIBGEN_H_
+
+#define basename(path) basename_const(path)
+#define dirname(path) dirname_const(path)
+
+char *basename(const char *);
+char *dirname(const char *);
+
+#endif