aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/root/Makefile4
-rw-r--r--devel/root/files/patch-interpreter_cling_lib_Interpreter_Interpreter.cpp4
2 files changed, 3 insertions, 5 deletions
diff --git a/devel/root/Makefile b/devel/root/Makefile
index aa522d8bf1f1..f3c04be51953 100644
--- a/devel/root/Makefile
+++ b/devel/root/Makefile
@@ -1,6 +1,6 @@
PORTNAME= root
DISTVERSION= 6.32.04
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel science math parallel python
MASTER_SITES= https://root.cern/download/
DISTFILES= ${PORTNAME}_v${DISTVERSION}.source${EXTRACT_SUFX}
@@ -12,8 +12,6 @@ WWW= https://root.cern/
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LGPL2_1.txt
-BROKEN_FreeBSD_15= fails to build: Patch for newest CURRENT is missing
-
BUILD_AND_RUN_DEPENDS= bash:shells/bash \
nlohmann-json>=3:devel/nlohmann-json
BUILD_DEPENDS= ${BUILD_AND_RUN_DEPENDS}
diff --git a/devel/root/files/patch-interpreter_cling_lib_Interpreter_Interpreter.cpp b/devel/root/files/patch-interpreter_cling_lib_Interpreter_Interpreter.cpp
index 68226edcbcfb..7afbaa8d87f7 100644
--- a/devel/root/files/patch-interpreter_cling_lib_Interpreter_Interpreter.cpp
+++ b/devel/root/files/patch-interpreter_cling_lib_Interpreter_Interpreter.cpp
@@ -5,8 +5,8 @@
#else
const char* LinkageCxx = Linkage;
+#ifdef __FreeBSD__
-+// atexit-like commands need 'throw()' specifier on FreeBSD 15 aarch64
-+#if defined(__aarch64__) && __FreeBSD_cc_version >= 1500000
++// atexit-like commands need 'throw()' specifier on FreeBSD 15
++#if __FreeBSD_cc_version >= 1500000
+ const char* Attr = " throw () ";
+#else
const char* Attr = "";