aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/antlr/Makefile9
-rw-r--r--devel/apache-commons-daemon/Makefile2
-rw-r--r--devel/criterion/Makefile2
-rw-r--r--devel/csmith/Makefile2
-rw-r--r--devel/darts/Makefile2
-rw-r--r--devel/directfb/Makefile7
-rw-r--r--devel/gengetopt/Makefile9
-rw-r--r--devel/genht/Makefile2
-rw-r--r--devel/gorm/Makefile2
-rw-r--r--devel/ice/Makefile4
-rw-r--r--devel/ice37/Makefile18
-rw-r--r--devel/libbinio/Makefile7
-rw-r--r--devel/libgee06/Makefile2
-rw-r--r--devel/libs11n/Makefile10
-rw-r--r--devel/libx86/Makefile2
-rw-r--r--devel/mingw32-gcc/Makefile2
-rw-r--r--devel/mpatrol/Makefile2
-rw-r--r--devel/p5-Compiler-Lexer/Makefile6
-rw-r--r--devel/pecl-yac/Makefile2
-rw-r--r--devel/py-donut-shellcode/Makefile2
-rw-r--r--devel/py-fam/Makefile5
-rw-r--r--devel/py-pyyaml5/Makefile2
-rw-r--r--devel/rubygem-cbor/Makefile2
-rw-r--r--devel/rubygem-curses/Makefile2
-rw-r--r--devel/rubygem-mmap2/Makefile2
-rw-r--r--devel/rubygem-posix-spawn/Makefile2
-rw-r--r--devel/rubygem-prometheus-client-mmap/Makefile2
-rw-r--r--devel/rubygem-rbtrace/Makefile2
-rw-r--r--devel/sfml/Makefile9
-rw-r--r--devel/sope/Makefile2
-rw-r--r--devel/tla/Makefile5
-rw-r--r--devel/z80-asm/Makefile2
32 files changed, 35 insertions, 96 deletions
diff --git a/devel/antlr/Makefile b/devel/antlr/Makefile
index 12e84da2e33f..136bfebfd35d 100644
--- a/devel/antlr/Makefile
+++ b/devel/antlr/Makefile
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
CONFLICTS= pccts
USES= compiler:c++11-lang gmake
+USE_CXXSTD= c++14
USE_JAVA= yes
HAS_CONFIGURE= yes
@@ -35,17 +36,9 @@ PORTDOCS= ANTLRException.gif closure.gif cpp-runtime.html \
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-extract:
(cd ${WRKSRC} && ${CP} antlr.jar antlrall.jar)
-post-patch:
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
- @${REINPLACE_CMD} -e 's|binary_function|__binary_function|' \
- ${WRKSRC}/lib/cpp/antlr/CharScanner.hpp
-.endif
-
do-install:
@${MKDIR} ${STAGEDIR}${JAVAJARDIR}
${INSTALL_DATA} ${WRKSRC}/antlr.jar ${STAGEDIR}${JAVAJARDIR}
diff --git a/devel/apache-commons-daemon/Makefile b/devel/apache-commons-daemon/Makefile
index b8665cdfbf87..df282cf4172a 100644
--- a/devel/apache-commons-daemon/Makefile
+++ b/devel/apache-commons-daemon/Makefile
@@ -29,7 +29,7 @@ PORTDOCS= *
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/devel/criterion/Makefile b/devel/criterion/Makefile
index bf011f60e4f7..df99d0bc3014 100644
--- a/devel/criterion/Makefile
+++ b/devel/criterion/Makefile
@@ -39,7 +39,7 @@ MESON_ARGS= -Dtests=false -Dsamples=false
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/devel/csmith/Makefile b/devel/csmith/Makefile
index d6672dde2d67..5cda8e795498 100644
--- a/devel/csmith/Makefile
+++ b/devel/csmith/Makefile
@@ -27,7 +27,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CPPFLAGS+= -Wno-error=enum-constexpr-conversion
.endif
diff --git a/devel/darts/Makefile b/devel/darts/Makefile
index 12aaeee8536b..2eeb3dc0b4dc 100644
--- a/devel/darts/Makefile
+++ b/devel/darts/Makefile
@@ -27,7 +27,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CPPFLAGS+= -Dregister=
.endif
diff --git a/devel/directfb/Makefile b/devel/directfb/Makefile
index 4dee67cfbcf5..76e1a3fe5d7d 100644
--- a/devel/directfb/Makefile
+++ b/devel/directfb/Makefile
@@ -21,6 +21,7 @@ USE_LDCONFIG= yes
USE_PERL5= build
GNU_CONFIGURE= yes
+USE_CXXSTD= c++14
CONFIGURE_ARGS= --disable-osx --disable-extra-warnings --disable-profiling \
--disable-debug --enable-debug-support --disable-trace \
--enable-text --enable-gettid --enable-network \
@@ -63,14 +64,10 @@ X11_CONFIGURE_ENABLE= x11
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 150
CFLAGS+= -Wno-error=int-conversion
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-CPPFLAGS+= -Dregister=
-.endif
-
# assembly files use old split syntax which clang doesn't like
.if ${ARCH:Marmv?} && ${COMPILER_TYPE} == "clang"
BUILD_DEPENDS+= as:devel/binutils
diff --git a/devel/gengetopt/Makefile b/devel/gengetopt/Makefile
index 1d1f56bad4df..b053fe0f4fdb 100644
--- a/devel/gengetopt/Makefile
+++ b/devel/gengetopt/Makefile
@@ -11,6 +11,7 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= makeinfo tar:xz
+USE_CXXSTD= c++14
GNU_CONFIGURE= yes
@@ -31,14 +32,6 @@ DOC_EXAMPLES= README.example cmdline1.c cmdline1.h cmdline2.c cmdline2.h \
TESTS_EXAMPLES= test_manual_help.c test_manual_help_cmd.c \
test_manual_help_cmd.ggo test_manual_help_cmd.h
-.include <bsd.port.options.mk>
-
-post-patch:
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
- @${REINPLACE_CMD} -e 's|std::unary_function|std::__unary_function|' \
- ${WRKSRC}/src/gm_utils.h
-.endif
-
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 \
${STAGEDIR}${MAN1PREFIX}/man/man1/
diff --git a/devel/genht/Makefile b/devel/genht/Makefile
index 502450972338..d5ec7e389717 100644
--- a/devel/genht/Makefile
+++ b/devel/genht/Makefile
@@ -22,7 +22,7 @@ OPTIONS_DEFINE= EXAMPLES
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/devel/gorm/Makefile b/devel/gorm/Makefile
index 3564b591a5be..c97e086b056d 100644
--- a/devel/gorm/Makefile
+++ b/devel/gorm/Makefile
@@ -22,7 +22,7 @@ DEFAULT_LIBVERSION= 1.1.0
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CPPFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index 597fc068ed4d..e63317ea70c6 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -19,6 +19,7 @@ MAKE_JOBS_UNSAFE= yes
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libmcpp.so:devel/mcpp
USES+= compiler:c++11-lang ssl
+USE_CXXSTD= c++11
.else
LIB_VRS= ${PORTVERSION:R:S|.||g}
LIB_DEPENDS+= libIce.so.${LIB_VRS}:devel/ice
@@ -60,9 +61,6 @@ MAKE_ENV+= NOTESTS=yes
.if ${SLAVE_PORT} == "no"
MAKE_ENV+= LD_LIBRARY_PATH=${WRKSRC}/cpp/lib:$$LD_LIBRARY_PATH
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-USE_CXXSTD= c++11
-.endif
.endif
.include <bsd.port.pre.mk>
diff --git a/devel/ice37/Makefile b/devel/ice37/Makefile
index efc69f6c4d2f..4f72f851a071 100644
--- a/devel/ice37/Makefile
+++ b/devel/ice37/Makefile
@@ -29,6 +29,7 @@ OPTIONS_DEFINE?= DEBUG STATIC TEST
OPTIONS_SUB= yes
USES+= compiler:c++14-lang iconv gmake
+USE_CXXSTD= c++14
DEBUG_MAKE_ENV= OPTIMIZE=no
TEST_ALL_TARGET_OFF= srcs
MAKE_ARGS+= V=1
@@ -116,23 +117,6 @@ post-patch:
${WRKSRC}/scripts/Util.py
@${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|g;' \
${WRKSRC}/scripts/Glacier2Util.py
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
- @${REINPLACE_CMD} -e 's|binary_function|__binary_function|g ; s|unary_function|__unary_function|g' \
- ${WRKSRC}/cpp/include/Ice/Proxy.h \
- ${WRKSRC}/cpp/include/IceUtil/Functional.h \
- ${WRKSRC}/cpp/src/IceGrid/AdapterCache.cpp \
- ${WRKSRC}/cpp/src/IceGrid/AllocatableObjectCache.cpp \
- ${WRKSRC}/cpp/src/IceGrid/Database.cpp \
- ${WRKSRC}/cpp/src/IceGrid/DescriptorHelper.cpp \
- ${WRKSRC}/cpp/src/IceGrid/NodeCache.cpp \
- ${WRKSRC}/cpp/src/IceGrid/ObjectCache.cpp \
- ${WRKSRC}/cpp/src/IceGrid/ServerCache.cpp \
- ${WRKSRC}/cpp/src/IceGrid/ServerI.cpp \
- ${WRKSRC}/cpp/src/IceGrid/Util.h \
- ${WRKSRC}/cpp/src/IcePatch2/Calc.cpp \
- ${WRKSRC}/cpp/src/IcePatch2Lib/Util.h \
- ${WRKSRC}/cpp/src/Slice/Parser.h
-.endif
IS_JAILED_CMD= ${SYSCTL} -n security.jail.jailed
JAILED_FILTER= --rfilter=IceDiscovery \
diff --git a/devel/libbinio/Makefile b/devel/libbinio/Makefile
index 37ed4e48083c..3bb993d6aada 100644
--- a/devel/libbinio/Makefile
+++ b/devel/libbinio/Makefile
@@ -10,6 +10,7 @@ WWW= https://adplug.github.io/libbinio/
LICENSE= LGPL21
USES= autoreconf compiler:c11 libtool pathfix
+USE_CXXSTD= c++14
USE_GITHUB= yes
USE_LDCONFIG= yes
@@ -21,12 +22,6 @@ INSTALL_TARGET= install-strip
PORTSCOUT= skipv:start
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-CPPFLAGS+= -Dregister=
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|^\(SUBDIRS\ =\).*|\1 src|' ${WRKSRC}/Makefile.am
diff --git a/devel/libgee06/Makefile b/devel/libgee06/Makefile
index 0a0bec668d88..5a8a5d77ae36 100644
--- a/devel/libgee06/Makefile
+++ b/devel/libgee06/Makefile
@@ -21,7 +21,7 @@ INSTALL_TARGET= install-strip
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/devel/libs11n/Makefile b/devel/libs11n/Makefile
index b16cb8f56611..0d1a61487adf 100644
--- a/devel/libs11n/Makefile
+++ b/devel/libs11n/Makefile
@@ -12,7 +12,7 @@ WWW= http://s11n.net/
LICENSE= PD
USES= uidfix zip
-USE_CXXSTD= c++11
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
PORTSCOUT= limitw:1,even
@@ -30,14 +30,6 @@ PLIST_SUB+= PROFILE=""
post-extract:
@${CP} ${PATCHDIR}/Makefile.bsd ${WRKSRC}/Makefile
-post-patch:
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
- @${REINPLACE_CMD} -e 's|auto_ptr|unique_ptr|' \
- ${WRKSRC}/../include/s11n.net/s11n/algo.tpp \
- ${WRKSRC}/../include/s11n.net/s11n/io/data_node_format.hpp \
- ${WRKSRC}/../include/s11n.net/s11n/io/data_node_io.hpp
-.endif
-
pre-install:
${MKDIR} ${STAGEDIR}${PREFIX}/include/s11n.net
${MKDIR} ${STAGEDIR}${PREFIX}/include/s11n.net/s11n
diff --git a/devel/libx86/Makefile b/devel/libx86/Makefile
index afcf96d05e8e..668dc90ca3d1 100644
--- a/devel/libx86/Makefile
+++ b/devel/libx86/Makefile
@@ -24,7 +24,7 @@ PLIST_FILES= include/libx86.h lib/libx86.a lib/libx86.so lib/libx86.so.1
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index d3e9a83b0dc9..124672e9b8e1 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -83,7 +83,7 @@ INFO+= libquadmath
.endif
INSTALL_TARGET= install-strip
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CPPFLAGS+= -Wno-error=increment-bool \
-Dregister=
.endif
diff --git a/devel/mpatrol/Makefile b/devel/mpatrol/Makefile
index 922d1aeec1d1..7774fa0a40eb 100644
--- a/devel/mpatrol/Makefile
+++ b/devel/mpatrol/Makefile
@@ -45,7 +45,7 @@ OPTIONS_DEFINE= DOCS
CFLAGS+= -DENVIRON=\"ENVIRON_64\" -DMP_INIT_SUPPORT=0
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=dynamic-exception-spec
.endif
diff --git a/devel/p5-Compiler-Lexer/Makefile b/devel/p5-Compiler-Lexer/Makefile
index 433d61c57629..b9cd137ac26c 100644
--- a/devel/p5-Compiler-Lexer/Makefile
+++ b/devel/p5-Compiler-Lexer/Makefile
@@ -16,11 +16,7 @@ BUILD_DEPENDS= p5-Module-Build-XSUtil>0:devel/p5-Module-Build-XSUtil
USES= perl5
USE_PERL5= modbuild
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
-CFLAGS+= -Dregister=
-.endif
+CFLAGS+= --std=c++14
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compiler/Lexer/Lexer.so
diff --git a/devel/pecl-yac/Makefile b/devel/pecl-yac/Makefile
index bfdd7fa61fe5..cd57c9ed6c27 100644
--- a/devel/pecl-yac/Makefile
+++ b/devel/pecl-yac/Makefile
@@ -18,7 +18,7 @@ MSGPACK_RUN_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/msgpack.so:devel/pecl-m
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/devel/py-donut-shellcode/Makefile b/devel/py-donut-shellcode/Makefile
index d17f837bc721..25af624e2344 100644
--- a/devel/py-donut-shellcode/Makefile
+++ b/devel/py-donut-shellcode/Makefile
@@ -18,7 +18,7 @@ DOS2UNIX_GLOB= *.py
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/devel/py-fam/Makefile b/devel/py-fam/Makefile
index a4bbbb814f37..b981f8c6e142 100644
--- a/devel/py-fam/Makefile
+++ b/devel/py-fam/Makefile
@@ -20,11 +20,10 @@ USE_PYTHON= distutils autoplist
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
-.endif
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 )
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
+.endif
pre-patch:
${INSTALL_DATA} ${FILESDIR}/setup.py ${WRKSRC}
diff --git a/devel/py-pyyaml5/Makefile b/devel/py-pyyaml5/Makefile
index 5e172b4a8147..da0ea93fb036 100644
--- a/devel/py-pyyaml5/Makefile
+++ b/devel/py-pyyaml5/Makefile
@@ -38,7 +38,7 @@ PYDISTUTILS_SETUP+= --without-libyaml
NO_ARCH= yes
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/devel/rubygem-cbor/Makefile b/devel/rubygem-cbor/Makefile
index 9a7f8555e951..be5047127d6c 100644
--- a/devel/rubygem-cbor/Makefile
+++ b/devel/rubygem-cbor/Makefile
@@ -13,7 +13,7 @@ USES= gem
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CONFIGURE_ARGS+= --with-cflags="-Wno-error=incompatible-function-pointer-types"
.endif
diff --git a/devel/rubygem-curses/Makefile b/devel/rubygem-curses/Makefile
index c8e8a1fb2716..bcb8430cc655 100644
--- a/devel/rubygem-curses/Makefile
+++ b/devel/rubygem-curses/Makefile
@@ -14,7 +14,7 @@ USES= gem ncurses
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CONFIGURE_ARGS+= --with-cflags="-Wno-error=incompatible-function-pointer-types"
.endif
diff --git a/devel/rubygem-mmap2/Makefile b/devel/rubygem-mmap2/Makefile
index 864ed2bac381..100da1ec9029 100644
--- a/devel/rubygem-mmap2/Makefile
+++ b/devel/rubygem-mmap2/Makefile
@@ -14,7 +14,7 @@ USES= gem
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CONFIGURE_ARGS+= --with-cflags="-Wno-error=incompatible-function-pointer-types"
.endif
diff --git a/devel/rubygem-posix-spawn/Makefile b/devel/rubygem-posix-spawn/Makefile
index c271dfe200b8..03eafbe82aca 100644
--- a/devel/rubygem-posix-spawn/Makefile
+++ b/devel/rubygem-posix-spawn/Makefile
@@ -16,7 +16,7 @@ PLIST_FILES= bin/posix-spawn-benchmark
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CONFIGURE_ARGS+= --with-cflags="-Wno-error=incompatible-function-pointer-types"
.endif
diff --git a/devel/rubygem-prometheus-client-mmap/Makefile b/devel/rubygem-prometheus-client-mmap/Makefile
index 60afa52c46fb..4805ca089ebf 100644
--- a/devel/rubygem-prometheus-client-mmap/Makefile
+++ b/devel/rubygem-prometheus-client-mmap/Makefile
@@ -15,7 +15,7 @@ USES= gem
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CONFIGURE_ARGS+= --with-cflags="-Wno-error=incompatible-function-pointer-types"
.endif
diff --git a/devel/rubygem-rbtrace/Makefile b/devel/rubygem-rbtrace/Makefile
index ae92c0f65cfc..46618c15559d 100644
--- a/devel/rubygem-rbtrace/Makefile
+++ b/devel/rubygem-rbtrace/Makefile
@@ -20,7 +20,7 @@ PLIST_FILES= bin/rbtrace
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CONFIGURE_ARGS+= --with-cflags="-Wno-error=incompatible-function-pointer-types"
.endif
diff --git a/devel/sfml/Makefile b/devel/sfml/Makefile
index 7299db5bd74b..b9d8a264b67f 100644
--- a/devel/sfml/Makefile
+++ b/devel/sfml/Makefile
@@ -15,6 +15,7 @@ GH_ACCOUNT= SFML
GH_PROJECT= SFML
USES= cmake compiler:c++11-lang
+USE_CXXSTD= c++14
CMAKE_ARGS= -DSFML_INSTALL_PKGCONFIG_FILES=ON \
-DSFML_USE_SYSTEM_DEPS=ON
USE_LDCONFIG= yes
@@ -58,14 +59,6 @@ DOXYGEN_IMPLIES= DOCS
EXAMPLES_CMAKE_BOOL= SFML_BUILD_EXAMPLES
-.include <bsd.port.options.mk>
-
-post-patch:
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
- @${REINPLACE_CMD} -e 's|auto_ptr|unique_ptr|' \
- ${WRKSRC}/src/SFML/Audio/AudioDevice.cpp
-.endif
-
post-install:
@${RM} ${STAGEDIR}${PREFIX}/*.pc
diff --git a/devel/sope/Makefile b/devel/sope/Makefile
index 52c317051d97..b2666788a8ca 100644
--- a/devel/sope/Makefile
+++ b/devel/sope/Makefile
@@ -45,7 +45,7 @@ PGSQL_USES= pgsql
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CPPFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/devel/tla/Makefile b/devel/tla/Makefile
index 1810d12b7a17..0262147dbdb0 100644
--- a/devel/tla/Makefile
+++ b/devel/tla/Makefile
@@ -41,11 +41,10 @@ ORIGWRKSRC= ${WRKDIR}/${DISTNAME}/src
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CPPFLAGS+= -Wno-error=int-conversion
-.endif
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 )
CPPFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
+.endif
pre-install:
${RM} -r ${ORIGWRKSRC}/docs-tla/PLUGIN \
diff --git a/devel/z80-asm/Makefile b/devel/z80-asm/Makefile
index 220e42101ae0..cc422953834c 100644
--- a/devel/z80-asm/Makefile
+++ b/devel/z80-asm/Makefile
@@ -24,7 +24,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif