aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/py-unearth/Makefile13
-rw-r--r--devel/py-unearth/distinfo6
-rw-r--r--devel/py-unearth/files/patch-pyproject.toml4
3 files changed, 14 insertions, 9 deletions
diff --git a/devel/py-unearth/Makefile b/devel/py-unearth/Makefile
index 842bcd43076b..799df6544159 100644
--- a/devel/py-unearth/Makefile
+++ b/devel/py-unearth/Makefile
@@ -1,5 +1,5 @@
PORTNAME= unearth
-PORTVERSION= 0.15.3
+PORTVERSION= 0.15.4
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,12 +18,17 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httpx>=0.27.0<1:www/py-httpx@${PY_FLAVOR} \
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flask>=2.1.2:www/py-flask@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-httpserver>=1.0.4:devel/py-pytest-httpserver@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-mock>=3.10.0:devel/py-pytest-mock@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests-wsgi-adapter>=0.4.1:www/py-requests-wsgi-adapter@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}trustme>=0.9.0:security/py-trustme@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}requests-wsgi-adapter>=0.4.1:www/py-requests-wsgi-adapter@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 31300
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}trustme>=0.9.0:security/py-trustme@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-unearth/distinfo b/devel/py-unearth/distinfo
index 79c1f445c28b..04b5b1cf8224 100644
--- a/devel/py-unearth/distinfo
+++ b/devel/py-unearth/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1716892296
-SHA256 (unearth-0.15.3.tar.gz) = 6324e51751d578362a961cd8a2c626a950b394516c71d85348d06ff59f3fbe14
-SIZE (unearth-0.15.3.tar.gz) = 283726
+TIMESTAMP = 1717568448
+SHA256 (unearth-0.15.4.tar.gz) = fbd85ab3fdb096f99c8266a20a7578a8f3130ad49f47cea8b138c008883b7b61
+SIZE (unearth-0.15.4.tar.gz) = 283788
diff --git a/devel/py-unearth/files/patch-pyproject.toml b/devel/py-unearth/files/patch-pyproject.toml
index d5ab4ebe309f..fdcf524d1a69 100644
--- a/devel/py-unearth/files/patch-pyproject.toml
+++ b/devel/py-unearth/files/patch-pyproject.toml
@@ -1,9 +1,9 @@
---- pyproject.toml.orig 2024-03-20 08:48:35 UTC
+--- pyproject.toml.orig 2024-06-04 10:06:37 UTC
+++ pyproject.toml
@@ -62,7 +62,7 @@ test = [
"flask>=2.1.2",
"requests-wsgi-adapter>=0.4.1",
- "trustme>=0.9.0",
+ "trustme>=0.9.0; python_version < \"3.13\"",
- "pytest-mock>=3.12.0",
+ "pytest-mock>=3.10.0",
]