aboutsummaryrefslogtreecommitdiff
path: root/editors/biew
diff options
context:
space:
mode:
Diffstat (limited to 'editors/biew')
-rw-r--r--editors/biew/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/editors/biew/Makefile b/editors/biew/Makefile
index 73a84fb83cef..a1a51685f0e9 100644
--- a/editors/biew/Makefile
+++ b/editors/biew/Makefile
@@ -37,6 +37,10 @@ MAKE_ARGS+= HOST_CFLAGS="${HOST_CFLAGS}" CC="${CC}" LD="${CC}" \
TARGET_OS=unix TARGET_SCREEN_LIB=curses \
USE_MOUSE=y
+.if ${MACHINE_ARCH} != "i386"
+MAKE_ARGS+= TARGET_PLATFORM=generic
+.endif
+
post-build:
@ ${LN} -sf ../../biewlib ${WRKSRC}/tools/biewhlp/biewlib
cd ${WRKSRC}/tools/biewhlp; ${GMAKE} ${MAKE_ARGS}