aboutsummaryrefslogtreecommitdiff
path: root/editors/cpeditor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/cpeditor/Makefile')
-rw-r--r--editors/cpeditor/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/editors/cpeditor/Makefile b/editors/cpeditor/Makefile
index 16f679f87312..f6f614f7b7e4 100644
--- a/editors/cpeditor/Makefile
+++ b/editors/cpeditor/Makefile
@@ -1,27 +1,34 @@
PORTNAME= cpeditor
-DISTVERSION= 6.10.1
+DISTVERSION= 7.0.1
CATEGORIES= editors devel
MAINTAINER= yuri@FreeBSD.org
COMMENT= Lightweight and cross-platform code editor for competitive programming
+WWW= https://cpeditor.org/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake:noninja compiler:c++14-lang desktop-file-utils qt:5
+USES= cmake:noninja compiler:c++17-lang desktop-file-utils kde:5 qt:5
USE_QT= core gui network widgets \
- buildtools_build linguisttools_build qmake_build
+ buildtools:build linguisttools:build qmake:build
+USE_KDE= syntaxhighlighting
+
USE_GITHUB= yes
-GH_TUPLE= \
- cpeditor:QCodeEditor:dbf8b26:cpeditor_QCodeEditor/third_party/QCodeEditor \
- itay-grudev:SingleApplication:d0c43a5:itay_grudev_SingleApplication/third_party/singleapplication \
- cpeditor:QtFindReplaceDialog:8528b6e:cpeditor_QtFindReplaceDialog/third_party/QtFindReplaceDialog \
- cpeditor:lsp-cpp:1825fd7:cpeditor_lsp_cpp/third_party/lsp-cpp \
+GH_TUPLE= itay-grudev:SingleApplication:494772e:itay_grudev_SingleApplication/third_party/singleapplication \
+ cpeditor:QtFindReplaceDialog:a86ed0b:cpeditor_QtFindReplaceDialog/third_party/QtFindReplaceDialog \
+ cpeditor:lsp-cpp:69c8afa:cpeditor_lsp_cpp/third_party/lsp-cpp \
cpeditor:qhttp:fd780d2a0bee1246f2ab0a17f6eebab6403fce64:cpeditor_qhttp/third_party/qhttp \
- MikeMirzayanov:testlib:f28d528:MikeMirzayanov_testlib/third_party/testlib
+ MikeMirzayanov:testlib:d0a0161:MikeMirzayanov_testlib/third_party/testlib
PLIST_FILES= bin/cpeditor \
share/applications/cpeditor.desktop \
+ ${DATADIR}/translations/el_GR.qm \
+ ${DATADIR}/translations/es_MX.qm \
+ ${DATADIR}/translations/pt_BR.qm \
+ ${DATADIR}/translations/ru_RU.qm \
+ ${DATADIR}/translations/zh_CN.qm \
+ ${DATADIR}/translations/zh_TW.qm \
share/icons/hicolor/512x512/apps/cpeditor.png \
share/metainfo/cpeditor.appdata.xml