aboutsummaryrefslogtreecommitdiff
path: root/editors/ecrire/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/ecrire/Makefile')
-rw-r--r--editors/ecrire/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/editors/ecrire/Makefile b/editors/ecrire/Makefile
new file mode 100644
index 000000000000..7d56e6dfc0fb
--- /dev/null
+++ b/editors/ecrire/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= ecrire
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.1-83
+DISTVERSIONSUFFIX= -gc6c81eb
+CATEGORIES= editors enlightenment
+DIST_SUBDIR= enlightenment
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= EFL (Enlightenment) graphical text editor
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libefl.so:devel/efl
+
+USES= cmake:outsource desktop-file-utils pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= Obsidian-StudiosInc
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CMAKE_BOOL= ENABLE_NLS
+
+.include <bsd.port.mk>