aboutsummaryrefslogtreecommitdiff
path: root/editors/elementary-code/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/elementary-code/Makefile')
-rw-r--r--editors/elementary-code/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/editors/elementary-code/Makefile b/editors/elementary-code/Makefile
index 02a26c051f00..27b8b2c397e7 100644
--- a/editors/elementary-code/Makefile
+++ b/editors/elementary-code/Makefile
@@ -1,11 +1,7 @@
PORTNAME= elementary-code
-DISTVERSION= 6.0.0
-PORTREVISION= 4
+DISTVERSION= 6.2.0
CATEGORIES= editors
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= a2607cce3a6b.patch:-p1 # https://github.com/elementary/code/pull/1165
-
MAINTAINER= miguel@gocobachi.dev
COMMENT= Code editor designed for elementary OS
@@ -13,8 +9,6 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= valac:lang/vala
-RUN_DEPENDS= droid-fonts-ttf>0:x11-fonts/droid-fonts-ttf \
- pkcheck:sysutils/polkit
LIB_DEPENDS= libatk-1.0.so:accessibility/atk \
libeditorconfig.so:editors/editorconfig-core-c \
libfontconfig.so:x11-fonts/fontconfig \
@@ -29,6 +23,8 @@ LIB_DEPENDS= libatk-1.0.so:accessibility/atk \
libvala-0.48.so:lang/vala \
libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
libzeitgeist-2.0.so:sysutils/zeitgeist
+RUN_DEPENDS= droid-fonts-ttf>0:x11-fonts/droid-fonts-ttf \
+ pkcheck:sysutils/polkit
USES= compiler:c++11-lang desktop-file-utils gettext gnome meson \
ninja pkgconfig python:3.6+,build xorg