aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/gedit/Makefile')
-rw-r--r--editors/gedit/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index eb5efb2e713c..c9286ba1ee3c 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= gedit
-PORTVERSION= 3.22.0
-PORTREVISION= 2
+PORTVERSION= 3.28.1
CATEGORIES= editors gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome3
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= Small but powerful text editor for GNOME 3 Desktop Environment
@@ -29,7 +28,7 @@ RUN_DEPENDS= iso-codes>=0:misc/iso-codes \
PORTSCOUT= limitw:1,even
USES= compiler:c11 desktop-file-utils gettext gmake gnome libtool \
- localbase pathfix pkgconfig python:3.2+ shebangfix tar:xz
+ localbase pathfix pkgconfig python:3.4+ shebangfix tar:xz
USE_CSTD= c11
USE_GNOME= cairo gdkpixbuf2 gtksourceview3 intlhack introspection \
libxml2 pygobject3
@@ -43,6 +42,7 @@ CPPFLAGS+= -Wno-error=format-nonliteral
CFLAGS+= -Wno-error=format-nonliteral
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
+SHEBANG_FILES= plugins/externaltools/data/send-to-fpaste.tool.in
PLIST_SUB= VERSION="3.14"
INSTALL_TARGET= install-strip