aboutsummaryrefslogtreecommitdiff
path: root/editors/xmlcopyeditor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/xmlcopyeditor/Makefile')
-rw-r--r--editors/xmlcopyeditor/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/editors/xmlcopyeditor/Makefile b/editors/xmlcopyeditor/Makefile
index df27701a748d..32de794c6ec3 100644
--- a/editors/xmlcopyeditor/Makefile
+++ b/editors/xmlcopyeditor/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xmlcopyeditor
-PORTVERSION= 1.2.0.9
-PORTREVISION= 1
+PORTVERSION= 1.2.0.11
CATEGORIES= editors
MASTER_SITES= SF/xml-copy-editor/${PORTNAME}-linux/${PORTVERSION}
@@ -16,16 +15,15 @@ USE_WX= 2.8+
WX_COMPS= wx contrib
WX_CONF_ARGS= absolute
WX_UNICODE= yes
-USES= gettext iconv
-USE_DOS2UNIX= yes
+USES= gettext iconv dos2unix
BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
-LIB_DEPENDS= xerces-c.3:${PORTSDIR}/textproc/xerces-c3 \
- xslt:${PORTSDIR}/textproc/libxslt \
- aspell:${PORTSDIR}/textproc/aspell \
- pcre:${PORTSDIR}/devel/pcre \
- xml2:${PORTSDIR}/textproc/libxml2 \
- expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libxerces-c.so.3:${PORTSDIR}/textproc/xerces-c3 \
+ libxslt.so:${PORTSDIR}/textproc/libxslt \
+ libaspell.so:${PORTSDIR}/textproc/aspell \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libxml2.so:${PORTSDIR}/textproc/libxml2 \
+ libexpat.so:${PORTSDIR}/textproc/expat2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -34,5 +32,4 @@ CPPFLAGS+= -I${LOCALBASE}/include \
-I${LOCALBASE}/include/libxml2 ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} ${ICONV_LIB}
-NO_STAGE= yes
.include <bsd.port.mk>