aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/wine-devel/Makefile')
-rw-r--r--emulators/wine-devel/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index b31f3708f9b8..4a617ff9631e 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -1,7 +1,7 @@
# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
PORTNAME= wine
-DISTVERSION= 7.1
+DISTVERSION= 7.2
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
@@ -165,9 +165,11 @@ pre-build:
post-install:
.if ${ARCH} == i386
${MV} ${STAGEDIR}${PREFIX}/bin/wineserver ${STAGEDIR}${PREFIX}/bin/wineserver32
+ ${ELFCTL} -e +noaslr ${STAGEDIR}${PREFIX}/bin/wine
${MV} ${STAGEDIR}${PREFIX}/bin/wine ${STAGEDIR}${PREFIX}/bin/wine.bin
${INSTALL_SCRIPT} ${FILESDIR}/wine.sh ${STAGEDIR}${PREFIX}/bin/wine
.else
+ ${ELFCTL} -e +noaslr ${STAGEDIR}${PREFIX}/bin/wine64
${MV} ${STAGEDIR}${PREFIX}/bin/wine64 ${STAGEDIR}${PREFIX}/bin/wine64.bin
${INSTALL_SCRIPT} ${FILESDIR}/wine.sh ${STAGEDIR}${PREFIX}/bin/wine64
${INSTALL_SCRIPT} ${FILESDIR}/wine-wow64.sh ${STAGEDIR}${PREFIX}/bin/wine