aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/wine/Makefile')
-rw-r--r--emulators/wine/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 0d0be527e97f..7c8929e25563 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -33,7 +33,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--verbose \
--disable-kerberos \
--disable-tests \
- --without-alsa \
--without-capi \
--without-coreaudio \
--without-dbus \
@@ -49,7 +48,6 @@ CONFIGURE_ARGS+=--verbose \
--without-netapi \
--without-opencl \
--without-osmesa \
- --with-oss \
--with-pcap \
--with-pthread \
--without-pulse \
@@ -73,7 +71,9 @@ SUB_FILES= pkg-message
PORTDATA= wine.inf
OPTIONS_DEFINE= CUPS DOCS DOSBOX GNUTLS LDAP LIBXSLT MPG123 OPENAL V4L WINEMAKER X11 GECKO MONO
-OPTIONS_DEFAULT=GNUTLS OPENAL X11
+OPTIONS_DEFAULT=GNUTLS OPENAL OSS X11
+OPTIONS_RADIO= AUDIO
+OPTIONS_RADIO_AUDIO= ALSA OSS
OPTIONS_SUB= yes
DOSBOX_DESC= Use DOSBox to run MS-DOS programs
@@ -84,6 +84,9 @@ MONO_DESC= Bundle Mono MSI package for Wine
PORTSCOUT= limit:^6\.0
+ALSA_CONFIGURE_ON= --with-alsa --without-oss
+ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
+
CUPS_CONFIGURE_WITH= cups
CUPS_LIB_DEPENDS= libcups.so:print/cups
@@ -108,6 +111,8 @@ MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
OPENAL_CONFIGURE_WITH= openal
OPENAL_USES= openal
+OSS_CONFIGURE_ON= --without-alsa --with-oss
+
V4L_CONFIGURE_WITH= v4l2
V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
V4L_LIB_DEPENDS= libv4l2.so:multimedia/libv4l