aboutsummaryrefslogtreecommitdiff
path: root/emulators/yuzu/files/patch-boost-1.86
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/yuzu/files/patch-boost-1.86')
-rw-r--r--emulators/yuzu/files/patch-boost-1.8613
1 files changed, 13 insertions, 0 deletions
diff --git a/emulators/yuzu/files/patch-boost-1.86 b/emulators/yuzu/files/patch-boost-1.86
new file mode 100644
index 000000000000..3bfa48206734
--- /dev/null
+++ b/emulators/yuzu/files/patch-boost-1.86
@@ -0,0 +1,13 @@
+https://github.com/boostorg/asio/issues/437
+https://github.com/boostorg/asio/commit/6ca7c4726e05
+
+--- CMakeLists.txt.orig 2024-03-01 07:57:00 UTC
++++ CMakeLists.txt
+@@ -275,6 +275,7 @@ add_definitions(-DBOOST_ASIO_DISABLE_CONCEPTS)
+
+ # boost asio's concept usage doesn't play nicely with some compilers yet.
+ add_definitions(-DBOOST_ASIO_DISABLE_CONCEPTS)
++add_definitions(-Dasync_operation=typename) # XXX Remove after Boost 1.87 upgrade
+ if (MSVC)
+ add_compile_options($<$<COMPILE_LANGUAGE:CXX>:/std:c++20>)
+