aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/cpmtools/Makefile2
-rw-r--r--emulators/hugo/Makefile2
-rw-r--r--emulators/qemu5/Makefile6
-rw-r--r--emulators/simh-hp2100/Makefile2
-rw-r--r--emulators/simh/Makefile2
-rw-r--r--emulators/virtualbox-ose-kmod-legacy/Makefile3
-rw-r--r--emulators/virtualbox-ose-kmod/Makefile3
-rw-r--r--emulators/wine/Makefile2
-rw-r--r--emulators/yaze-ag/Makefile2
-rw-r--r--emulators/z80pack/Makefile2
10 files changed, 18 insertions, 8 deletions
diff --git a/emulators/cpmtools/Makefile b/emulators/cpmtools/Makefile
index a45463f0d898..d2c6c0970dba 100644
--- a/emulators/cpmtools/Makefile
+++ b/emulators/cpmtools/Makefile
@@ -14,4 +14,6 @@ WRKSRC= ${WRKDIR}/cpm
CFLAGS+= -Wno-return-type
+CONFLICTS_INSTALL= yaze-ag
+
.include <bsd.port.mk>
diff --git a/emulators/hugo/Makefile b/emulators/hugo/Makefile
index cb03643ebd50..6c8a11f1cc80 100644
--- a/emulators/hugo/Makefile
+++ b/emulators/hugo/Makefile
@@ -61,4 +61,6 @@ CONFIGURE_ENV+= ac_cv_lib_SDL_mixer_main=no \
ac_cv_lib_vorbisfile_main=no
.endif
+CONFLICTS_INSTSLL= gohugo
+
.include <bsd.port.mk>
diff --git a/emulators/qemu5/Makefile b/emulators/qemu5/Makefile
index 4a4da7520e8e..484d0c006c0b 100644
--- a/emulators/qemu5/Makefile
+++ b/emulators/qemu5/Makefile
@@ -22,9 +22,9 @@ LIB_DEPENDS= libnettle.so:security/nettle \
libzstd.so:archivers/zstd
FLAVORS= default nox11
-default_CONFLICTS_INSTALL= qemu*
+default_CONFLICTS_INSTALL= qemu-devel qemu-nox11 qemu42 qemu5
nox11_PKGNAMESUFFIX= 5-nox11
-nox11_CONFLICTS_INSTALL= qemu*
+nox11_CONFLICTS_INSTALL= qemu qemu-devel qemu42 qemu5
nox11_COMMENT= (without X11)
USES= bison compiler:c11 cpe gmake gnome iconv:wchar_t ninja perl5 \
@@ -34,6 +34,8 @@ USE_PERL5= build
USE_PYTHON= distutils noflavors
USE_XORG= pixman
+CONFLICTS_INSTALL= qemu qemu-devel qemu-nox11 qemu42 qemu5
+
HAS_CONFIGURE= yes
PORTSCOUT= limit:^5\.
diff --git a/emulators/simh-hp2100/Makefile b/emulators/simh-hp2100/Makefile
index 0536bb1f735f..ab8b977b8cc8 100644
--- a/emulators/simh-hp2100/Makefile
+++ b/emulators/simh-hp2100/Makefile
@@ -24,7 +24,7 @@ USES= gmake dos2unix zip
NO_WRKSUBDIR= yes
-CONFLICTS_INSTALL= simh-3.[789]*
+CONFLICTS_INSTALL= simh
DOS2UNIX_GLOB= *.c *.h *.txt *.mak makefile
SUB_FILES= hp2100.1
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index e50400bed867..83f965a56866 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -24,6 +24,8 @@ CFLAGS+= -Wno-format-extra-args -Wno-comment
MAKE_ENV= GCC="${CC}" CFLAGS_O="${CFLAGS}" USE_NETWORK=1
MAKEFILE= makefile
+CONFLICTS_INSTALL= simh-hp2100
+
SUB_FILES= pkg-message simh.1
READMES= 0readme_${PORTVERSION:R:S/.//}.txt 0readme_ethernet.txt
diff --git a/emulators/virtualbox-ose-kmod-legacy/Makefile b/emulators/virtualbox-ose-kmod-legacy/Makefile
index 6e70e1e83651..623b0afc8dbb 100644
--- a/emulators/virtualbox-ose-kmod-legacy/Makefile
+++ b/emulators/virtualbox-ose-kmod-legacy/Makefile
@@ -37,8 +37,7 @@ CONFIGURE_ARGS+= --disable-alsa \
--disable-xpcom
CONFIGURE_ARGS+= --nofatal --with-gcc="${CC}" --with-g++="${CXX}"
-CONFLICTS_INSTALL= virtualbox-ose-kmod-devel \
- virtualbox-ose-kmod
+CONFLICTS_INSTALL= virtualbox-ose-kmod
PORTSCOUT= limit:^5\.
diff --git a/emulators/virtualbox-ose-kmod/Makefile b/emulators/virtualbox-ose-kmod/Makefile
index b9aa595f0eba..04f0cc7079f6 100644
--- a/emulators/virtualbox-ose-kmod/Makefile
+++ b/emulators/virtualbox-ose-kmod/Makefile
@@ -36,8 +36,7 @@ CONFIGURE_ARGS+= --disable-alsa \
--disable-xpcom
CONFIGURE_ARGS+= --nofatal --with-gcc="${CC}" --with-g++="${CXX}"
-CONFLICTS_INSTALL= virtualbox-ose-kmod-devel \
- virtualbox-ose-kmod-legacy
+CONFLICTS_INSTALL= virtualbox-ose-kmod-legacy
OPTIONS_DEFINE= DEBUG VIMAGE
OPTIONS_DEFAULT=VIMAGE
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index d2dd94577dde..ae5fb377d3ee 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -28,7 +28,7 @@ USE_SDL= sdl2
CPE_VENDOR= winehq
-CONFLICTS_INSTALL= wine-devel-*
+CONFLICTS_INSTALL= wine-devel
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--verbose \
diff --git a/emulators/yaze-ag/Makefile b/emulators/yaze-ag/Makefile
index 3ace3558505e..67489c5ac711 100644
--- a/emulators/yaze-ag/Makefile
+++ b/emulators/yaze-ag/Makefile
@@ -13,6 +13,8 @@ LIB_DEPENDS= libreadline.so:devel/readline
USES= compiler:c11
+CONFLICTS_INSTALL= cpmtools
+
MAKEFILE= Makefile_freebsd
MAKE_ENV= BINDIR=${PREFIX}/bin \
DESTDIR="${STAGEDIR}" \
diff --git a/emulators/z80pack/Makefile b/emulators/z80pack/Makefile
index e50a2ded04a9..683e6d0fa9d2 100644
--- a/emulators/z80pack/Makefile
+++ b/emulators/z80pack/Makefile
@@ -7,6 +7,8 @@ EXTRACT_SUFX= tgz
MAINTAINER= se@FreeBSD.org
COMMENT= Complete CP/M-80 emulator
+CONFLICTS_INSTALL= hextools
+
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE