aboutsummaryrefslogtreecommitdiff
path: root/finance/alkimia/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/alkimia/Makefile')
-rw-r--r--finance/alkimia/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/finance/alkimia/Makefile b/finance/alkimia/Makefile
index 7857e06f6fde..bbb5390fda24 100644
--- a/finance/alkimia/Makefile
+++ b/finance/alkimia/Makefile
@@ -1,5 +1,5 @@
PORTNAME= alkimia
-PORTVERSION= 8.1.0
+PORTVERSION= 8.1.1
CATEGORIES= finance kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
@@ -16,16 +16,17 @@ RUN_DEPENDS= p5-Date-Manip>=0:devel/p5-Date-Manip \
p5-libwww>=0:www/p5-libwww
USES= cmake compiler:c++11-lang kde:5 pathfix perl5 qt:5 \
- shebangfix tar:xz
+ shebangfix tar:xz xorg
USE_LDCONFIG= yes
USE_KDE= attica auth codecs completion config configwidgets coreaddons \
- i18n iconthemes jobwidgets kio newstuff service sonnet \
+ i18n iconthemes jobwidgets kio newstuff service solid sonnet \
textwidgets widgetsaddons windowsystem xmlgui ecm_build
USE_PERL5= run
USE_QT= concurrent core dbus declarative gui network widgets xml \
buildtools_build qmake_build
+USE_XORG= x11
-CMAKE_OFF= BUILD_DOXYGEN_DOCS
+CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_Doxygen
PLIST_SUB= VER=${PORTVERSION:R}
SHEBANG_FILES= src/financequote.pl
@@ -58,7 +59,7 @@ TOOLS_DESC= Build tools
TOOLS_CMAKE_BOOL= BUILD_TOOLS
WEBENGINE_DESC= Qt Web Engine support
-WEBENGINE_USE= QT=webengine
+WEBENGINE_USE= QT=location,printsupport,webchannel,webengine
WEBENGINE_CMAKE_BOOL= BUILD_WITH_WEBENGINE
WEBKIT_DESC= Qt WebKit support