aboutsummaryrefslogtreecommitdiff
path: root/finance/py-yahooquery/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/py-yahooquery/Makefile')
-rw-r--r--finance/py-yahooquery/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/finance/py-yahooquery/Makefile b/finance/py-yahooquery/Makefile
new file mode 100644
index 000000000000..25ca0a70c6b6
--- /dev/null
+++ b/finance/py-yahooquery/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= yahooquery
+DISTVERSION= 2.3.7
+CATEGORIES= finance python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/g}-${PORTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python wrapper for an unofficial Yahoo Finance API
+WWW= https://yahooquery.dpguthrie.com/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>0:devel/py-poetry-core@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.12.2:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=4.9.3:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=2.0.3:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-futures>=1.0.1:www/py-requests-futures@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.31.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>=4.65.0:misc/py-tqdm@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>