aboutsummaryrefslogtreecommitdiff
path: root/finance/quickfix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/quickfix/Makefile')
-rw-r--r--finance/quickfix/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/finance/quickfix/Makefile b/finance/quickfix/Makefile
index 07b08e04b4fc..9d4619274c79 100644
--- a/finance/quickfix/Makefile
+++ b/finance/quickfix/Makefile
@@ -33,7 +33,7 @@ PGSQL_CONFIGURE_WITH= postgresql
MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
MYSQL_VARS= IGNORE_WITH_MYSQL=80
-PYTHON_USES= python:3.7
+PYTHON_USES= python:3.8
PYTHON_CONFIGURE_WITH= python3
RUBY_USES= ruby
RUBY_CONFIGURE_WITH= ruby
@@ -45,6 +45,10 @@ INSTALL_TARGET=install-strip
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MPYTHON}
+BROKEN= fails to build
+.endif
+
.if ${ARCH} != amd64 && ${ARCH} != i386
CXXFLAGS+= -DENABLE_BOOST_ATOMIC_COUNT
LIB_DEPENDS+= libboost_system.so:devel/boost-libs