aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
Diffstat (limited to 'finance')
-rw-r--r--finance/gnucash/Makefile7
-rw-r--r--finance/gnucash/files/patch-src_gnome-utils_gnc-html.c11
2 files changed, 15 insertions, 3 deletions
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index 75a55bf3e58b..e642c10df0ee 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -3,12 +3,12 @@
# Whom: David O'Brien (obrien@NUXI.com)
#
# $FreeBSD$
-# $MCom: ports/finance/gnucash/Makefile,v 1.12 2007/02/23 18:27:51 ahze Exp $
+# $MCom: ports/finance/gnucash/Makefile,v 1.14 2007/03/13 05:58:37 marcus Exp $
#
PORTNAME= gnucash
PORTVERSION= 2.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= finance gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.gnucash.org/pub/gnucash/sources/stable/
@@ -80,7 +80,8 @@ PLIST_SUB= AQBANKING="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|$${datarootdir}/info|${PREFIX}/info|' \
+ @${REINPLACE_CMD} -e 's|$${datarootdir}/info|${PREFIX}/info| ; \
+ s|libgtkhtml-3.8|libgtkhtml-3.14|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|$$(datadir)/aclocal|${PREFIX}/share/aclocal|' \
${WRKSRC}/Makefile.in
diff --git a/finance/gnucash/files/patch-src_gnome-utils_gnc-html.c b/finance/gnucash/files/patch-src_gnome-utils_gnc-html.c
new file mode 100644
index 000000000000..92058ac13ade
--- /dev/null
+++ b/finance/gnucash/files/patch-src_gnome-utils_gnc-html.c
@@ -0,0 +1,11 @@
+--- src/gnome-utils/gnc-html.c.orig Tue Feb 20 23:18:48 2007
++++ src/gnome-utils/gnc-html.c Tue Feb 20 23:18:38 2007
+@@ -1325,7 +1325,7 @@
+ return;
+ }
+
+- gtk_html_print(GTK_HTML(html->html), ps->context);
++ gtk_html_print_page(GTK_HTML(html->html), ps->context);
+ gnc_print_session_done(ps);
+ }
+