aboutsummaryrefslogtreecommitdiff
path: root/ftp/bareftp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/bareftp/Makefile')
-rw-r--r--ftp/bareftp/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/ftp/bareftp/Makefile b/ftp/bareftp/Makefile
new file mode 100644
index 000000000000..8ade60e82792
--- /dev/null
+++ b/ftp/bareftp/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: bareftp
+# Date created: Sat June 20, 2009
+# Whom: Chris Petrik (chris@officialunix.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= bareftp
+PORTVERSION= 0.2.3
+CATEGORIES= ftp
+MASTER_SITES= http://www.bareftp.org/release/
+
+MAINTAINER= chris@officialunix.com
+COMMENT= Ftp client made in C sharp
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --datarootdir="${PREFIX}/share" --libdir="${LOCALBASE}/lib" \
+ --localedir="${PREFIX}/share/locale" --includedir="${LOCALBASE}/include"
+
+INSTALLS_ICONS= yes
+USE_GETTEXT= yes
+USE_GNOME= gtksharp20 gnomesharp20
+USE_GMAKE= yes
+
+# TODO
+# Ugly way but configure ignore "--localedir=" fu* ;/
+pre-build:
+ @${REINPLACE_CMD} -e 's|$$(prefix)/$$(DATADIRNAME)|${PREFIX}/share|g' \
+ ${WRKSRC}/po/Makefile
+
+.include <bsd.port.mk>