aboutsummaryrefslogtreecommitdiff
path: root/ftp/gproftpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/gproftpd/Makefile')
-rw-r--r--ftp/gproftpd/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/ftp/gproftpd/Makefile b/ftp/gproftpd/Makefile
new file mode 100644
index 000000000000..9bf96f84387f
--- /dev/null
+++ b/ftp/gproftpd/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: gproftpd
+# Date created: 14 September 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gproftpd
+PORTVERSION= 8.3.2
+CATEGORIES= ftp
+MASTER_SITES= http://mange.dynalias.org/linux/gproftpd/
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= Gtk2 Frontend for proftpd daemon
+
+RUN_DEPENDS= proftpd:${PORTSDIR}/ftp/proftpd
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:261
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20 pkgconfig
+
+PORTDOCS= AUTHORS README ChangeLog COPYING
+
+post-extract:
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "****** Make sure you have mod_tls and mod_radius enabled in ftp/proftpd ******"
+ @${ECHO_CMD} ""
+ @sleep 3
+ @${CP} ${FILESDIR}/crypt.h ${WRKSRC}/src/
+
+post-configure:
+ @${REINPLACE_CMD} -e "s:\<crypt.h\>:\"crypt.h\":" ${WRKSRC}/src/functions.c
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>