aboutsummaryrefslogtreecommitdiff
path: root/ftp/proftpd-devel
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/proftpd-devel')
-rw-r--r--ftp/proftpd-devel/Makefile205
-rw-r--r--ftp/proftpd-devel/distinfo3
-rw-r--r--ftp/proftpd-devel/files/patch-ah10
-rw-r--r--ftp/proftpd-devel/files/patch-contrib::mod_sql_mysql.c11
-rw-r--r--ftp/proftpd-devel/files/patch-doc::Configuration.html18
-rw-r--r--ftp/proftpd-devel/files/patch-module::mod_auth_pam.c11
-rw-r--r--ftp/proftpd-devel/files/patch-sample-configurations_basic.conf68
-rw-r--r--ftp/proftpd-devel/files/patch-src_proftpd.8.in15
-rw-r--r--ftp/proftpd-devel/files/proftpd.sh.in43
-rw-r--r--ftp/proftpd-devel/pkg-descr13
-rw-r--r--ftp/proftpd-devel/pkg-message8
-rw-r--r--ftp/proftpd-devel/pkg-plist12
12 files changed, 0 insertions, 417 deletions
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
deleted file mode 100644
index 94a66af6a136..000000000000
--- a/ftp/proftpd-devel/Makefile
+++ /dev/null
@@ -1,205 +0,0 @@
-# New ports collection makefile for: proftpd
-# Date created: 26 January 1998
-# Whom: Stephane Legrand
-#
-# $FreeBSD$
-#
-
-PORTNAME= proftpd
-DISTVERSION= 1.3.0rc3
-PORTREVISION= 0
-CATEGORIES= ftp
-MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
- ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
- ftp://ftp.dataguard.no/ftp/pub/proftpd/distrib/source/ \
- ftp://spirit.bentel.sk/mirrors/Proftpd/distrib/source/ \
- ftp://proftpd.networkedsystems.co.uk/distrib/source/ \
- ftp://ftp.ethereal.com/mirrors/ftp.proftpd.org/distrib/source/ \
- ftp://mirror.cybercomm.nl/pub/proftpd/distrib/source/
-
-MAINTAINER?= mharo@FreeBSD.org
-COMMENT?= Highly configurable ftp daemon
-
-MAN1= ftpcount.1 ftpwho.1 ftptop.1
-MAN5= xferlog.5
-MAN8= proftpd.8 ftpshut.8 ftpdctl.8
-
-PORTDOCSdoc= Configuration.html faq.html
-PORTDOCScontrib=mod_ifsession.html mod_radius.html mod_rewrite.html \
- mod_tls.html mod_wrap.html ftpasswd.html
-PORTDOCS= ${PORTDOCSdoc} ${PORTDOCScontrib}
-
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_BZIP2= yes
-USE_REINPLACE= yes
-
-USE_RC_SUBR= proftpd.sh
-
-CONFIGURE_ARGS= --localstatedir=/var/run \
- --sysconfdir=${EXAMPLESDIR}/etc \
- --disable-sendfile
-
-OPTIONS= IPV6 "Use IPv6" off \
- LDAP "Use LDAP" off \
- MYSQL "Use MySQL" off \
- POSTGRESQL "Use Postgres" off \
- OPENSSL "Include mod_tls" off \
- QUOTA "Include mod_quota" off \
- IFSESSION "Include mod_ifsession" on \
- README "Include mod_readme" on \
- RATIO "Include mod_ratio" on \
- REWRITE "Include mod_rewrite" on \
- WRAP "Include mod_wrap" on \
- RADIUS "Include mod_radius" off
-
-MODULES?=
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_RATIO)
-MODULES:=${MODULES}:mod_ratio
-.endif
-
-.if defined(WITH_README)
-MODULES:=${MODULES}:mod_readme
-.endif
-
-.if defined(WITH_REWRITE)
-MODULES:=${MODULES}:mod_rewrite
-.endif
-
-.if defined(WITH_WRAP)
-MODULES:=${MODULES}:mod_wrap
-.endif
-
-.if defined(WITH_RADIUS)
-MODULES:=${MODULES}:mod_radius
-.endif
-
-.if defined(WITH_SETPASSENT)
-CONFIGURE_ARGS+= --enable-force-setpassent
-.endif
-
-.if defined(WITHOUT_PAM)
-CONFIGURE_ARGS+= --disable-auth-pam
-.endif
-
-.if defined(WITH_IPV6)
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
-
-.if defined(WITHOUT_IPV6)
-CONFIGURE_ARGS+= --disable-ipv6
-.endif
-
-#allow user to override
-MODULES?= mod_ratio:mod_readme:mod_rewrite:mod_wrap:mod_ifsession
-
-INCLUDEDIRS=
-LIBDIRS=
-
-.if defined(WITH_LDAP)
-USE_OPENLDAP= yes
-MODULES:=${MODULES}:mod_ldap
-INCLUDEDIRS:=${INCLUDEDIRS}:${LOCALBASE}/include
-LIBDIRS:=${LIBDIRS}:${LOCALBASE}/lib
-.endif
-
-.if defined(WITH_MYSQL)
-USE_MYSQL= yes
-MODULES:=${MODULES}:mod_sql:mod_sql_mysql
-INCLUDEDIRS:=${INCLUDEDIRS}:${LOCALBASE}/include
-LIBDIRS:=${LIBDIRS}:${LOCALBASE}/lib/mysql
-.endif
-
-.if defined(WITH_POSTGRESQL)
-USE_PGSQL= yes
-MODULES:=${MODULES}:mod_sql:mod_sql_postgres
-INCLUDEDIRS:=${INCLUDEDIRS}:${LOCALBASE}/include
-LIBDIRS:=${LIBDIRS}:${LOCALBASE}/lib
-.endif
-
-.if defined(WITH_OPENSSL)
-CFLAGS+= -DHAVE_OPENSSL
-USE_OPENSSL= yes
-.include <${PORTSDIR}/Mk/bsd.openssl.mk>
-PROFTPD_LIBS+= -lssl -lcrypto -L${LOCALBASE}/lib
-MODULES:=${MODULES}:mod_tls
-.endif
-
-.if defined(WITH_CTRLS)
-CONFIGURE_ARGS+= --enable-ctrls
-PLIST_FILES+= sbin/ftpdctl
-.if !defined(WITHOUT_CTRLS_ADMIN)
-MODULES:=${MODULES}:mod_ctrls_admin
-.endif
-.endif
-
-.if defined(WITH_QUOTA)
-MODULES:=${MODULES}:mod_quotatab:mod_quotatab_file
-.if defined(WITH_LDAP)
-MODULES:=${MODULES}:mod_quotatab_ldap
-.endif
-.if defined(WITH_POSTGRESQL) || defined(WITH_MYSQL)
-MODULES:=${MODULES}:mod_quotatab_sql
-.endif
-.endif
-
-# mod_ifsession should be the last item in the modules list
-.if defined(WITH_IFSESSION)
-MODULES:=${MODULES}:mod_ifsession
-.endif
-
-# Keep this here below, in case similar constructs need to be made
-CONFIGURE_ENV+= "LIBS=${PROFTPD_LIBS}"
-
-.if !empty(MODULES)
-CONFIGURE_ARGS+= --with-modules=${MODULES}
-.endif
-
-.if !empty(INCLUDEDIRS)
-CONFIGURE_ARGS+= --with-includes=${INCLUDEDIRS}
-.endif
-
-.if !empty(LIBDIRS)
-CONFIGURE_ARGS+= --with-libraries=${LIBDIRS}
-.endif
-
-MODULES!=${ECHO} ${MODULES} | ${SED} -e 's,^:,,' -e 's,:$$,,'
-
-pre-configure:
- @${ECHO_MSG} "==> Configuring with ${MODULES}"
-
-post-configure:
- ${REINPLACE_CMD} -e 's:${EXAMPLESDIR}:${PREFIX}:' ${WRKSRC}/config.h
- ${REINPLACE_CMD} -e 's: -lnsl::' ${WRKSRC}/Make.rules
- ${REINPLACE_CMD} -e 's:/usr/sbin:${PREFIX}/sbin:' \
- -e 's:/usr/bin:${PREFIX}/bin:' \
- ${WRKSRC}/src/proftpd.8 ${WRKSRC}/utils/ftpshut.8 \
- ${WRKSRC}/utils/ftpcount.1
-
-post-install:
- [ -f ${PREFIX}/etc/proftpd.conf ] || \
- ${CP} ${EXAMPLESDIR}/etc/proftpd.conf ${PREFIX}/etc/proftpd.conf
-
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/proftpd
-.for f in ${PORTDOCSdoc}
- @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${PREFIX}/share/doc/proftpd
-.endfor
-.for f in ${PORTDOCScontrib}
- @${INSTALL_DATA} ${WRKSRC}/doc/contrib/${f} ${PREFIX}/share/doc/proftpd
-.endfor
-.endif
-
-.if !defined(WITHOUT_PAM)
- @${CAT} ${PKGMESSAGE}
-.endif
-
-.if defined(WITH_CTRLS)
- @${INSTALL_PROGRAM} ${WRKSRC}/ftpdctl ${PREFIX}/sbin/ftpdctl
- @${INSTALL_MAN} ${WRKSRC}/src/ftpdctl.8 ${PREFIX}/man/man8/ftpdctl.8
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/ftp/proftpd-devel/distinfo b/ftp/proftpd-devel/distinfo
deleted file mode 100644
index 56be108e1985..000000000000
--- a/ftp/proftpd-devel/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (proftpd-1.3.0rc3.tar.bz2) = 050c3e2caec0d930f8a331e7b3ec0931
-SHA256 (proftpd-1.3.0rc3.tar.bz2) = ee181d7fe22b849589d9d886e5a4ed40fbe205cc14f8f4c95cc1db629c95ca97
-SIZE (proftpd-1.3.0rc3.tar.bz2) = 1377481
diff --git a/ftp/proftpd-devel/files/patch-ah b/ftp/proftpd-devel/files/patch-ah
deleted file mode 100644
index 1cea5a3ce4a0..000000000000
--- a/ftp/proftpd-devel/files/patch-ah
+++ /dev/null
@@ -1,10 +0,0 @@
---- modules/mod_auth_unix.c.orig Thu May 13 23:40:18 2004
-+++ modules/mod_auth_unix.c Thu May 13 23:40:27 2004
-@@ -57,6 +57,7 @@
- #endif /* HAVE_HPSECURITY_H or HPUX10 or HPUX11 */
-
- #if defined(HAVE_PROT_H) || defined(COMSEC)
-+# include <krb.h>
- # include <prot.h>
- #endif
-
diff --git a/ftp/proftpd-devel/files/patch-contrib::mod_sql_mysql.c b/ftp/proftpd-devel/files/patch-contrib::mod_sql_mysql.c
deleted file mode 100644
index 9da89767a223..000000000000
--- a/ftp/proftpd-devel/files/patch-contrib::mod_sql_mysql.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- contrib/mod_sql_mysql.c.orig Sun Nov 2 00:30:13 2003
-+++ contrib/mod_sql_mysql.c Sun Nov 2 00:30:23 2003
-@@ -134,7 +134,7 @@
-
- #define _MYSQL_PORT "3306"
-
--#include <mysql.h>
-+#include <mysql/mysql.h>
- #include "conf.h"
- #include "../contrib/mod_sql.h"
-
diff --git a/ftp/proftpd-devel/files/patch-doc::Configuration.html b/ftp/proftpd-devel/files/patch-doc::Configuration.html
deleted file mode 100644
index 400699d4f8f1..000000000000
--- a/ftp/proftpd-devel/files/patch-doc::Configuration.html
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./doc/Configuration.html.orig Wed Jan 29 12:27:24 2003
-+++ ./doc/Configuration.html Sat Mar 15 11:34:14 2003
-@@ -4226,7 +4226,7 @@
- ></DT
- ><DD
- ><P
-->ftp</P
-+>ftpd</P
- ></DD
- ><DT
- ><PRE
-@@ -32252,4 +32252,4 @@
- ></DIV
- ></BODY
- ></HTML
-->
-\ No newline at end of file
-+>
diff --git a/ftp/proftpd-devel/files/patch-module::mod_auth_pam.c b/ftp/proftpd-devel/files/patch-module::mod_auth_pam.c
deleted file mode 100644
index 6092c58f6d26..000000000000
--- a/ftp/proftpd-devel/files/patch-module::mod_auth_pam.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./modules/mod_auth_pam.c.orig Thu Jan 2 13:25:20 2003
-+++ ./modules/mod_auth_pam.c Sat Mar 15 11:35:00 2003
-@@ -57,7 +57,7 @@
- #endif /* HAVE_PAM_PAM_APPL_H */
-
- static pam_handle_t * pamh = NULL;
--static char * pamconfig = "ftp";
-+static char * pamconfig = "ftpd";
- static char * pam_user = NULL;
- static char * pam_pass = NULL;
- static size_t pam_user_len = 0;
diff --git a/ftp/proftpd-devel/files/patch-sample-configurations_basic.conf b/ftp/proftpd-devel/files/patch-sample-configurations_basic.conf
deleted file mode 100644
index fa3f8dfc355e..000000000000
--- a/ftp/proftpd-devel/files/patch-sample-configurations_basic.conf
+++ /dev/null
@@ -1,68 +0,0 @@
---- sample-configurations/basic.conf.orig Fri Jun 17 15:10:06 2005
-+++ sample-configurations/basic.conf Fri Jun 17 15:10:43 2005
-@@ -1,3 +1,7 @@
-+#
-+# To have more informations about Proftpd configuration
-+# look at : http://www.proftpd.org/
-+#
- # This is a basic ProFTPD configuration file (rename it to
- # 'proftpd.conf' for actual use. It establishes a single server
- # and a single anonymous login. It assumes that you have a user/group
-@@ -6,6 +10,7 @@
- ServerName "ProFTPD Default Installation"
- ServerType standalone
- DefaultServer on
-+ScoreboardFile /var/run/proftpd.scoreboard
-
- # Port 21 is the standard FTP port.
- Port 21
-@@ -40,23 +45,29 @@
-
- # A basic anonymous configuration, no upload directories. If you do not
- # want anonymous users, simply delete this entire <Anonymous> section.
--<Anonymous ~ftp>
-- User ftp
-- Group ftp
--
-- # We want clients to be able to login with "anonymous" as well as "ftp"
-- UserAlias anonymous ftp
--
-- # Limit the maximum number of anonymous logins
-- MaxClients 10
--
-- # We want 'welcome.msg' displayed at login, and '.message' displayed
-- # in each newly chdired directory.
-- DisplayLogin welcome.msg
-- DisplayFirstChdir .message
--
-- # Limit WRITE everywhere in the anonymous chroot
-- <Limit WRITE>
-- DenyAll
-- </Limit>
--</Anonymous>
-+#########################################################################
-+# #
-+# Uncomment lines with only one # to allow basic anonymous access #
-+# #
-+#########################################################################
-+
-+#<Anonymous ~ftp>
-+# User ftp
-+# Group ftp
-+
-+ ### We want clients to be able to login with "anonymous" as well as "ftp"
-+ # UserAlias anonymous ftp
-+
-+ ### Limit the maximum number of anonymous logins
-+ # MaxClients 10
-+
-+ ### We want 'welcome.msg' displayed at login, and '.message' displayed
-+ ### in each newly chdired directory.
-+ # DisplayLogin welcome.msg
-+ # DisplayFirstChdir .message
-+
-+ ### Limit WRITE everywhere in the anonymous chroot
-+ # <Limit WRITE>
-+ # DenyAll
-+ # </Limit>
-+#</Anonymous>
diff --git a/ftp/proftpd-devel/files/patch-src_proftpd.8.in b/ftp/proftpd-devel/files/patch-src_proftpd.8.in
deleted file mode 100644
index 9578f30ec3b3..000000000000
--- a/ftp/proftpd-devel/files/patch-src_proftpd.8.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/proftpd.8.in.orig Sat Sep 18 07:40:30 2004
-+++ src/proftpd.8.in Thu Nov 3 15:35:56 2005
-@@ -22,6 +22,12 @@
- connection to the FTP service is made, or alternatively it can be run as a
- standalone daemon.
- .PP
-+.br
-+Each successful and failed ftp(1) session is logged using syslog with a
-+facility of LOG_FTP. Note: LOG_FTP messages are not displayed
-+by syslogd(8) by default, and may have to be enabled in syslogd(8)'s
-+configuration file.
-+.PP
- When
- .B proftpd
- is run in standalone mode and it receives a SIGHUP then it will reread its
diff --git a/ftp/proftpd-devel/files/proftpd.sh.in b/ftp/proftpd-devel/files/proftpd.sh.in
deleted file mode 100644
index 5e72d10cfb88..000000000000
--- a/ftp/proftpd-devel/files/proftpd.sh.in
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: proftpd
-# REQUIRE: DAEMON
-# BEFORE: LOGIN
-# KEYWORD: shutdown
-
-#
-# Add the following lines to /etc/rc.conf to enable proftpd:
-#
-#proftpd_enable="YES"
-#
-# See proftpd(8) for flags
-#
-
-. %%RC_SUBR%%
-
-name=proftpd
-rcvar=`set_rcvar`
-
-command=%%PREFIX%%/sbin/proftpd
-pidfile=/var/run/proftpd.pid
-required_files=%%PREFIX%%/etc/proftpd.conf
-
-stop_postcmd=stop_postcmd
-
-stop_postcmd()
-{
- rm -f $pidfile
-}
-
-# set defaults
-
-proftpd_enable=${proftpd_enable:-"NO"}
-proftpd_flags=${proftpd_flags:-""}
-
-extra_commands="reload"
-
-load_rc_config $name
-run_rc_command "$1"
diff --git a/ftp/proftpd-devel/pkg-descr b/ftp/proftpd-devel/pkg-descr
deleted file mode 100644
index 4b1860f1cddc..000000000000
--- a/ftp/proftpd-devel/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-ProFTPD is a highly configurable ftp daemon for unix
-and unix-like operating systems. ProFTPD is designed
-to be somewhat of a "drop-in" replacement for wu-ftpd
-with a configuration format like Apache.
-
-Full online documentation is available at
-http://www.proftpd.org/, including a server
-configuration directive reference manual.
-
-- Stephane Legrand
-stephane@lituus.fr
-
-WWW: http://www.proftpd.org/
diff --git a/ftp/proftpd-devel/pkg-message b/ftp/proftpd-devel/pkg-message
deleted file mode 100644
index c9cfcdbe940b..000000000000
--- a/ftp/proftpd-devel/pkg-message
+++ /dev/null
@@ -1,8 +0,0 @@
-###
-Make sure you have the following lines in your PAM configuration file
-so that ProFTPd's PAM module can authenticate users correctly.
-
-ftpd auth required pam_unix.so try_first_pass
-ftpd account required pam_unix.so try_first_pass
-ftpd session required pam_permit.so
-###
diff --git a/ftp/proftpd-devel/pkg-plist b/ftp/proftpd-devel/pkg-plist
deleted file mode 100644
index 61c08dc01ad8..000000000000
--- a/ftp/proftpd-devel/pkg-plist
+++ /dev/null
@@ -1,12 +0,0 @@
-bin/ftpcount
-bin/ftpdctl
-bin/ftptop
-bin/ftpwho
-@unexec if cmp -s %D/etc/proftpd.conf %D/%%EXAMPLESDIR%%/etc/proftpd.conf; then rm -f %D/etc/proftpd.conf; fi
-%%EXAMPLESDIR%%/etc/proftpd.conf
-@exec if [ ! -f %D/etc/proftpd.conf ] ; then cp -p %D/%F %B/proftpd.conf; fi
-sbin/ftpshut
-sbin/in.proftpd
-sbin/proftpd
-@dirrm %%EXAMPLESDIR%%/etc
-@dirrm %%EXAMPLESDIR%%