aboutsummaryrefslogtreecommitdiff
path: root/games/asc/files/patch-source::mapedit::Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'games/asc/files/patch-source::mapedit::Makefile.in')
-rw-r--r--games/asc/files/patch-source::mapedit::Makefile.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/games/asc/files/patch-source::mapedit::Makefile.in b/games/asc/files/patch-source::mapedit::Makefile.in
new file mode 100644
index 000000000000..37beaa311c0f
--- /dev/null
+++ b/games/asc/files/patch-source::mapedit::Makefile.in
@@ -0,0 +1,27 @@
+
+$FreeBSD$
+
+--- source/mapedit/Makefile.in.orig Mon Jan 29 01:11:06 2001
++++ source/mapedit/Makefile.in Sat Feb 17 18:19:08 2001
+@@ -76,10 +76,10 @@
+ bin_PROGRAMS = ascmapedit ascmap2pcx
+
+ ascmapedit_SOURCES = edevents.cpp edgen.cpp edglobal.cpp edmain.cpp edselfnt.cpp edmisc.cpp weather.cpp typen.cpp strtmesg.cpp stack.cpp spfst.cpp sgstream.cpp pd.cpp palette.cpp newfont.cpp misc.cpp loadpcxc.cpp loaders.cpp loadbi3.cpp dlg_box.cpp dialog.cpp basestrm.cpp basegfx.cpp attack.cpp CLoadable.cpp Property.cpp PropertyGroup.cpp gameoptions.cpp Named.cpp buildingtype.cpp vehicletype.cpp containerbase.cpp mapalgorithms.cpp viewcalculation.cpp gamemap.cpp password.cpp password_dialog.cpp research.cpp mapdisplay.cpp ascstring.cpp graphicset.cpp
+-ascmapedit_LDADD = ../sdl/libsdl.a ../libs/triangul/libtriangul.a -lSDL -lpthread @LDADDLIBBZ2@
++ascmapedit_LDADD = ../sdl/libsdl.a ../libs/triangul/libtriangul.a @LDADDLIBBZ2@
+
+ ascmap2pcx_SOURCES = map2pcx.cpp weather.cpp typen.cpp strtmesg.cpp stack.cpp spfst.cpp sgstream.cpp pd.cpp palette.cpp newfont.cpp misc.cpp loadpcxc.cpp loaders.cpp loadbi3.cpp dlg_box.cpp dialog.cpp basestrm.cpp basegfx.cpp attack.cpp CLoadable.cpp Property.cpp PropertyGroup.cpp gameoptions.cpp Named.cpp buildingtype.cpp vehicletype.cpp containerbase.cpp mapalgorithms.cpp viewcalculation.cpp gamemap.cpp password.cpp password_dialog.cpp research.cpp mapdisplay.cpp ascstring.cpp graphicset.cpp
+-ascmap2pcx_LDADD = ../sdl/libsdl.a ../libs/triangul/libtriangul.a -lSDL -lpthread -lSDL_image @LDADDLIBBZ2@
++ascmap2pcx_LDADD = ../sdl/libsdl.a ../libs/triangul/libtriangul.a -lSDL_image @LDADDLIBBZ2@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../../config.h
+ CONFIG_CLEAN_FILES =
+@@ -87,7 +87,7 @@
+
+
+ DEFS = @DEFS@ -I. -I$(srcdir) -I../..
+-CPPFLAGS = @CPPFLAGS@
++CPPFLAGS = @CPPFLAGS@ -DPREFIX=\"$(prefix)\"
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ ascmapedit_OBJECTS = edevents.o edgen.o edglobal.o edmain.o edselfnt.o \