aboutsummaryrefslogtreecommitdiff
path: root/games/chessx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/chessx/Makefile')
-rw-r--r--games/chessx/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/games/chessx/Makefile b/games/chessx/Makefile
index 591637558301..7ea3139d624b 100644
--- a/games/chessx/Makefile
+++ b/games/chessx/Makefile
@@ -1,15 +1,14 @@
PORTNAME= chessx
-PORTVERSION= 1.5.7
-PORTREVISION= 1
+DISTVERSION= 1.6.0
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/beta
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= alexey@pentode.fi
COMMENT= Qt 5 chess database application
WWW= https://chessx.sourceforge.io/
LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_FILE= ${WRKSRC}/COPYING.md
USES= compiler:c++11-lang desktop-file-utils gl gmake qmake qt:5 tar:tgz
USE_GL= gl
@@ -18,7 +17,11 @@ USE_QT= concurrent core gui multimedia network opengl printsupport svg \
PLIST_FILES= bin/chessx \
share/applications/chessx.desktop \
- share/pixmaps/chessx.png
+ share/pixmaps/chessx.png \
+ share/metainfo/io.sourceforge.ChessX.metainfo.xml \
+ share/icons/hicolor/128x128/apps/chessx.png \
+ share/icons/hicolor/32x32/apps/chessx-32.png \
+ share/icons/hicolor/64x64/apps/chessx-64.png
OPTIONS_DEFINE= CRAFTY STOCKFISH
@@ -31,4 +34,10 @@ STOCKFISH_RUN_DEPENDS= stockfish:games/stockfish
post-configure:
( cd ${BUILD_WRKSRC} && ${LRELEASE} ${WRKSRC}/${PORTNAME}.pro )
+# the FIND command works around a bug in FreeBSD 12.4 strip(1) which
+# leaves junk files when attempting to strip a file of unrecognised format.
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/chessx
+ ${FIND} ${STAGEDIR}${PREFIX} -name 'ecp.????????' -delete
+
.include <bsd.port.mk>