aboutsummaryrefslogtreecommitdiff
path: root/games/crrcsim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/crrcsim/Makefile')
-rw-r--r--games/crrcsim/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/games/crrcsim/Makefile b/games/crrcsim/Makefile
index f7262e6f4e3c..3677420133be 100644
--- a/games/crrcsim/Makefile
+++ b/games/crrcsim/Makefile
@@ -11,36 +11,32 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Model-airplane flight simulation program
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
-LIB_DEPENDS= portaudio.2:${PORTSDIR}/audio/portaudio2 \
- jpeg:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libportaudio.so.2:${PORTSDIR}/audio/portaudio2 \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_SDL= sdl
USE_GL= gl glu
CPPFLAGS+= -I${LOCALBASE}/include/portaudio2 -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib/portaudio2 -L${LOCALBASE}/lib
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
PORTDOCS= *
-
-MAN1= crrcsim.1
+PORTDATA= *
DESKTOP_ENTRIES="CRRCsim" \
"Model-airplane flight simulation program" \
"${DATADIR}/icons/crrcsim.png" \
"crrcsim" \
"Game;Simulation;" \
- false
+ ""
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=DOCS
post-patch:
@${REINPLACE_CMD} -e '/portaudio/ s|==|=|' ${WRKSRC}/configure
-.if ! ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-pkgdataDATA||; \
- /^SUBDIRS =/ s|=.*|= man|' ${WRKSRC}/documentation/Makefile.in
-.endif
.include <bsd.port.mk>