aboutsummaryrefslogtreecommitdiff
path: root/games/endless-sky/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/endless-sky/Makefile')
-rw-r--r--games/endless-sky/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/games/endless-sky/Makefile b/games/endless-sky/Makefile
new file mode 100644
index 000000000000..c2ecb670e7bb
--- /dev/null
+++ b/games/endless-sky/Makefile
@@ -0,0 +1,34 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= endless-sky
+PORTVERSION= 0.8.4
+DISTVERSIONPREFIX= v
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Space exploration and combat game similar to Escape Velocity
+
+LICENSE= GPLv3 # or later
+
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
+
+BROKEN_FreeBSD_9= does not build
+
+USE_GITHUB= yes
+
+USES= compiler:c++11-lib jpeg localbase openal scons
+USE_SDL= sdl2
+USE_GL= gl glew
+INSTALLS_ICONS= yes
+
+PORTDATA= *
+
+post-build:
+ @${REINPLACE_CMD} -e 's|/usr/local/|${PREFIX}/|; s|share/games|share|' \
+ ${WRKSRC}/source/Files.cpp
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>