aboutsummaryrefslogtreecommitdiff
path: root/games/fgfs-base
diff options
context:
space:
mode:
Diffstat (limited to 'games/fgfs-base')
-rw-r--r--games/fgfs-base/Makefile68
-rw-r--r--games/fgfs-base/distinfo4
-rw-r--r--games/fgfs-base/files/patch-aa12
-rw-r--r--games/fgfs-base/files/patch-ab32
-rw-r--r--games/fgfs-base/files/patch-ac79
-rw-r--r--games/fgfs-base/files/patch-ad27
-rw-r--r--games/fgfs-base/files/patch-ae11
-rw-r--r--games/fgfs-base/files/patch-af11
-rw-r--r--games/fgfs-base/files/patch-ag94
-rw-r--r--games/fgfs-base/patches.tools/Makefile.gpc19
-rw-r--r--games/fgfs-base/patches.tools/disable-tools67
-rw-r--r--games/fgfs-base/patches.tools/gfc-patch-aa21
-rw-r--r--games/fgfs-base/pkg-comment1
-rw-r--r--games/fgfs-base/pkg-descr10
-rw-r--r--games/fgfs-base/pkg-plist178
-rw-r--r--games/fgfs-base/pkg-plist.notools168
16 files changed, 0 insertions, 802 deletions
diff --git a/games/fgfs-base/Makefile b/games/fgfs-base/Makefile
deleted file mode 100644
index 99ce7284acd6..000000000000
--- a/games/fgfs-base/Makefile
+++ /dev/null
@@ -1,68 +0,0 @@
-# New ports collection makefile for: flightgear
-# Date created: 26 June 1999
-# Whom: Brian Buchanan <brian@CSUA.Berkeley.EDU>
-#
-# $FreeBSD$
-#
-
-PORTNAME= FlightGear
-PORTVERSION= 0.6.1
-CATEGORIES= games
-MASTER_SITES= ftp://ftp.flightgear.org/pub/fgfs/Source/ \
- ftp://ftp.flightgear.org/pub/fgfs/Shared/
-DISTFILES= ${DISTNAME}.tar.gz \
- fgfs-base-${PORTVERSION}.tar.gz
-
-MAINTAINER= brian@CSUA.Berkeley.EDU
-
-BUILD_DEPENDS= ${X11BASE}/lib/libsl.a:${PORTSDIR}/x11-toolkits/plib
-RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
-
-EXTRACT_ONLY= ${DISTNAME}.tar.gz
-
-.if defined(BUILD_SCENERY_TOOLS)
-MASTER_SITES+= ftp://ftp.cs.man.ac.uk/pub/amurta/
-DISTFILES+= gfc-0.8.8.1b.tar.gz gpc231.tar.Z
-EXTRACT_ONLY+= gfc-0.8.8.1b.tar.gz gpc231.tar.Z
-NO_PACKAGE= "gpc's license conflicts with the GPL"
-CONFIGURE_ENV+= CPPFLAGS=-I${WRKSRC}/gfcgpc/include \
- LDFLAGS=-L${WRKSRC}/gfcgpc/lib
-ADDPATCHES= ${MASTERDIR}/patches.tools/gfc-patch-aa
-
-pre-configure:
- @(cd ${WRKDIR}/gfc-0.8.8.1b; ./configure --prefix=${WRKSRC}/gfcgpc; \
- ${GMAKE}; ${GMAKE} install; \
- ${CP} ${MASTERDIR}/patches.tools/Makefile.gpc \
- ${WRKDIR}/gpc231/Makefile; \
- cd ${WRKDIR}/gpc231; ${GMAKE}; \
- ${GMAKE} PREFIX=${WRKSRC}/gfcgpc install)
-.else
-PLIST= ${MASTERDIR}/pkg/PLIST.notools
-ADDPATCHES= ${MASTERDIR}/patches.tools/disable-tools
-USE_AUTOCONF= yes
-.endif
-
-USE_NEWGCC= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--bindir=${PREFIX}/FlightGear/bin
-USE_GMAKE= yes
-
-pre-patch:
- @( cd ${WRKDIR}; \
- for i in ${ADDPATCHES} ; do \
- ${PATCH} -s < $${i}; \
- done )
-
-post-configure:
- @(cd ${WRKSRC};touch Makefile.in */Makefile.in */*/Makefile.in \
- */*/*/Makefile.in; \
- ./config.status)
-
-pre-install:
- cd ${PREFIX}; \
- ${TAR} xzf ${DISTDIR}/fgfs-base-${PORTVERSION}.tar.gz
-
-post-install:
- ${MV} ${PREFIX}/FlightGear/bin/runfgfs ${PREFIX}/bin
-
-.include <bsd.port.mk>
diff --git a/games/fgfs-base/distinfo b/games/fgfs-base/distinfo
deleted file mode 100644
index 27d44e2b6a66..000000000000
--- a/games/fgfs-base/distinfo
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 (FlightGear-0.6.1.tar.gz) = 148b2649bb4891af3cdfaf209e5a72a9
-MD5 (fgfs-base-0.6.1.tar.gz) = 69ab47bc4a8333409e875e34c53a3016
-MD5 (gfc-0.8.8.1b.tar.gz) = c28405037a0129a71eeca9e0dd5b831e
-MD5 (gpc231.tar.Z) = 6d4aaa30268af5b152b7a4d82937fc84
diff --git a/games/fgfs-base/files/patch-aa b/games/fgfs-base/files/patch-aa
deleted file mode 100644
index 714120858204..000000000000
--- a/games/fgfs-base/files/patch-aa
+++ /dev/null
@@ -1,12 +0,0 @@
---- Simulator/Main/splash.cxx.orig Wed May 12 19:16:17 1999
-+++ Simulator/Main/splash.cxx Sat Jun 26 22:31:54 1999
-@@ -123,7 +123,8 @@
- xglMatrixMode(GL_PROJECTION);
- xglPushMatrix();
- xglLoadIdentity();
-- gluOrtho2D(0, current_view.get_winWidth(), 0, current_view.get_winHeight());
-+ if (current_view.get_winWidth() && current_view.get_winHeight())
-+ gluOrtho2D(0, current_view.get_winWidth(), 0, current_view.get_winHeight());
- xglMatrixMode(GL_MODELVIEW);
- xglPushMatrix();
- xglLoadIdentity();
diff --git a/games/fgfs-base/files/patch-ab b/games/fgfs-base/files/patch-ab
deleted file mode 100644
index 81840b3e61a7..000000000000
--- a/games/fgfs-base/files/patch-ab
+++ /dev/null
@@ -1,32 +0,0 @@
---- Tools/Construct/Parallel/client.cxx.orig Fri May 21 13:18:06 1999
-+++ Tools/Construct/Parallel/client.cxx Sat Jun 26 22:32:01 1999
-@@ -20,6 +20,11 @@
-
- #include <Bucket/newbucket.hxx>
-
-+/* the next lines are to define BSD */
-+/* see http://www.freebsd.org/handbook/porting.html for why we do this */
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-
- #define MAXBUF 1024
- #define BUSY_WAIT_TIME 30
-@@ -45,6 +50,9 @@
-
- // check if the host system is free of interactive users
- int system_free() {
-+
-+#ifndef BSD
-+
- struct utmp *uptr;
-
- setutent();
-@@ -61,6 +69,7 @@
- }
-
- endutent();
-+#endif
- return 1;
- }
-
diff --git a/games/fgfs-base/files/patch-ac b/games/fgfs-base/files/patch-ac
deleted file mode 100644
index e21b86479735..000000000000
--- a/games/fgfs-base/files/patch-ac
+++ /dev/null
@@ -1,79 +0,0 @@
---- Simulator/Time/fg_time.cxx.orig Mon Apr 19 13:18:31 1999
-+++ Simulator/Time/fg_time.cxx Sun Jun 27 19:34:43 1999
-@@ -49,6 +49,13 @@
- # include <sys/time.h> // for get/setitimer, gettimeofday, struct timeval
- #endif
-
-+// The next lines are to define BSD
-+// See http://www.freebsd.org/handbook/porting.html for why we do this
-+
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-+
- #include <Debug/logstream.hxx>
- #include <Astro/sky.hxx>
- #include <Astro/solarsystem.hxx>
-@@ -366,6 +373,11 @@
- // For now we assume that if daylight is not defined in
- // /usr/include/time.h that we have a machine with a BSD behaving
- // mktime()
-+# ifdef BSD
-+# define USE_TIME_GM 1
-+# endif
-+
-+
- # if !defined(HAVE_DAYLIGHT)
- # define MK_TIME_IS_GMT 1
- # endif
-@@ -383,6 +395,10 @@
- mt.tm_sec = sec;
- mt.tm_isdst = -1; // let the system determine the proper time zone
-
-+# ifdef USE_TIME_GM
-+ return ( timegm(&mt) );
-+# else
-+
- # if defined( MK_TIME_IS_GMT )
- return ( mktime(&mt) );
- # else // ! defined ( MK_TIME_IS_GMT )
-@@ -424,6 +440,7 @@
- return ( start_gmt );
- # endif // ! defined( TIMEZONE_OFFSET_WORKS )
- # endif // ! defined ( MK_TIME_IS_GMT )
-+# endif
- }
-
- // Fix up timezone if using ftime()
---- Tests/test-mktime.cxx.orig Sun Jun 27 19:21:42 1999
-+++ Tests/test-mktime.cxx Sun Jun 27 19:34:13 1999
-@@ -20,6 +20,12 @@
- # include <sys/time.h> // for get/setitimer, gettimeofday, struct timeval
- #endif
-
-+// The next lines are to define BSD
-+// See http://www.freebsd.org/handbook/porting.html for why we do this
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-+
- #define LST_MAGIC_TIME_1998 890481600
-
-
-@@ -73,6 +79,8 @@
- mt.tm_sec = 0;
- mt.tm_isdst = -1; // let the system determine the proper time zone
-
-+# ifdef BSD
-+ return ( timegm(&mt) );
- # if defined( MK_TIME_IS_GMT )
- return ( mktime(&mt) );
- # else // ! defined ( MK_TIME_IS_GMT )
-@@ -110,6 +118,7 @@
- return ( start_gmt );
- # endif // ! defined( TIMEZONE_OFFSET_WORKS )
- # endif // ! defined ( MK_TIME_IS_GMT )
-+# endif
- }
-
-
diff --git a/games/fgfs-base/files/patch-ad b/games/fgfs-base/files/patch-ad
deleted file mode 100644
index f7a358370e18..000000000000
--- a/games/fgfs-base/files/patch-ad
+++ /dev/null
@@ -1,27 +0,0 @@
---- Simulator/Main/Makefile.in.orig Sun Jun 27 21:12:00 1999
-+++ Simulator/Main/Makefile.in Sun Jun 27 21:12:12 1999
-@@ -75,7 +75,7 @@
-
- bin_PROGRAMS = fgfs
-
--bin_SCRIPTS = runfgfs runfgfs.bat
-+bin_SCRIPTS = runfgfs
-
- fgfs_SOURCES = \
- GLUTkey.cxx GLUTkey.hxx GLUTmain.cxx \
---- Simulator/Main/runfgfs.in.orig Tue Apr 6 16:39:22 1999
-+++ Simulator/Main/runfgfs.in Sun Jun 27 21:44:52 1999
-@@ -29,11 +29,11 @@
- # print "-> $prefix\n";
-
- # potential names of Flight Gear executable to try
--@files = ( "fg", "fg.exe" );
-+@files = ( "fgfs" );
-
- # search for the executable
- # potential paths where the executable may be found
--@paths = ( ".", "Simulator/Main", $prefix );
-+@paths = ( ".", "Simulator/Main", $prefix, "$prefix/FlightGear" );
-
- $savepath = "";
- $savefile = "";
diff --git a/games/fgfs-base/files/patch-ae b/games/fgfs-base/files/patch-ae
deleted file mode 100644
index 09fd65c6ea1f..000000000000
--- a/games/fgfs-base/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- Lib/Makefile.in.orig Sun Jun 27 21:48:15 1999
-+++ Lib/Makefile.in Sun Jun 27 21:48:20 1999
-@@ -197,7 +197,7 @@
- install-data: install-data-recursive
- @$(NORMAL_INSTALL)
-
--install: install-recursive
-+install: #install-recursive
- @:
-
- uninstall: uninstall-recursive
diff --git a/games/fgfs-base/files/patch-af b/games/fgfs-base/files/patch-af
deleted file mode 100644
index 8b08b48a85db..000000000000
--- a/games/fgfs-base/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- Include/Makefile.in.orig Thu Jul 1 15:20:48 1999
-+++ Include/Makefile.in Thu Jul 1 15:20:55 1999
-@@ -90,7 +90,7 @@
-
- TAR = tar
- GZIP = --best
--all: Makefile config.h
-+all:
-
- .SUFFIXES:
- $(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
diff --git a/games/fgfs-base/files/patch-ag b/games/fgfs-base/files/patch-ag
deleted file mode 100644
index b0cb8e6139bd..000000000000
--- a/games/fgfs-base/files/patch-ag
+++ /dev/null
@@ -1,94 +0,0 @@
-From brian@CSUA.Berkeley.EDU Thu Sep 9 20:25:32 1999
-Return-Path: <brian@CSUA.Berkeley.EDU>
-Received: from soda.CSUA.Berkeley.EDU (soda.CSUA.Berkeley.EDU [128.32.43.52])
- by hub.freebsd.org (Postfix) with ESMTP id 4DD7F152D2
- for <FreeBSD-gnats-submit@freebsd.org>; Thu, 9 Sep 1999 20:25:30 -0700 (PDT)
- (envelope-from brian@CSUA.Berkeley.EDU)
-Received: from smarter.than.nu (ida-89-77.Reshall.Berkeley.EDU [169.229.89.77])
- by soda.CSUA.Berkeley.EDU (8.8.8/) via ESMTP id UAA17320
- for <FreeBSD-gnats-submit@freebsd.org>; Thu, 9 Sep 1999 20:24:55 -0700 (PDT)
- env-from (brian@CSUA.Berkeley.EDU)
-Message-Id: <Pine.BSF.4.10.9909092019290.691-100000@smarter.than.nu>
-Date: Thu, 9 Sep 1999 20:24:54 -0700 (PDT)
-From: "Brian W. Buchanan" <brian@CSUA.Berkeley.EDU>
-To: FreeBSD-gnats-submit@freebsd.org
-Subject: [PATCH] Fix games/flightgear build under 3.3RC
-
->Number: 13674
->Category: ports
->Synopsis: Patch for games/flightgear for 3.3
->Confidential: no
->Severity: critical
->Priority: high
->Responsible: freebsd-ports
->State: open
->Quarter:
->Keywords:
->Date-Required:
->Class: sw-bug
->Submitter-Id: current-users
->Arrival-Date: Thu Sep 9 20:30:00 PDT 1999
->Closed-Date:
->Last-Modified:
->Originator: Brian Buchanan
->Release: FreeBSD 4.0-CURRENT i386
->Organization:
->Environment:
->Description:
-
-Satoshi's build logs show FlightGear failing under 3.3 due to some
-implicit typecasting that the compiler has no problem with under 4.0, but
-barfs at under 3.3. A patch is attached. I don't have any way to test
-this under 3.3, nor do I know if anything later in the build process fails
-under 3.3, so if someone could do a quick check and fix any other trivial
-little things before the ports freeze, it would be appreciated.
-
->How-To-Repeat:
->Fix:
-
-Add patches/patch-ag:
-
---- Simulator/GUI/gui.cxx.old Thu Sep 9 20:11:55 1999
-+++ Simulator/GUI/gui.cxx Thu Sep 9 20:13:07 1999
-@@ -149,7 +149,7 @@
- glutSetCursor(GLUT_CURSOR_INHERIT);
- #endif
- #if (GLUT_API_VERSION >= 4 || GLUT_XLIB_IMPLEMENTATION >= 9)
-- glutWarpPointer( glutGet(GLUT_SCREEN_WIDTH)/2, glutGet(GLUT_SCREEN_HEIGHT)/2);
-+ glutWarpPointer( glutGet((GLenum)GLUT_SCREEN_WIDTH)/2, glutGet((GLenum)GLUT_SCREEN_HEIGHT)/2);
- #endif
- }
-
-@@ -160,7 +160,7 @@
- glutSetCursor(GLUT_CURSOR_NONE);
- #else // I guess this is what we want to do ??
- #if (GLUT_API_VERSION >= 4 || GLUT_XLIB_IMPLEMENTATION >= 9)
-- glutWarpPointer( glutGet(GLUT_SCREEN_WIDTH), glutGet(GLUT_SCREEN_HEIGHT));
-+ glutWarpPointer( glutGet((GLenum)GLUT_SCREEN_WIDTH), glutGet((GLenum)GLUT_SCREEN_HEIGHT));
- #endif
- #endif
- }
-@@ -195,7 +195,7 @@
- if( restore ) {
- glutSetCursor(cursor);
- } else {
-- cursor = glutGet( GLUT_WINDOW_CURSOR );
-+ cursor = glutGet( (GLenum)GLUT_WINDOW_CURSOR );
- #ifdef WIN32
- TurnCursorOn();
- #endif
-@@ -595,7 +595,7 @@
- // Install our fast fonts
- fntpath.append( "typewriter.txf" );
- guiFntHandle = new fntTexFont ;
-- guiFntHandle -> load ( fntpath.c_str() ) ;
-+ guiFntHandle -> load ( (char *)fntpath.c_str() ) ;
- puFont GuiFont ( guiFntHandle, 15 ) ;
- puSetDefaultFonts( GuiFont, GuiFont ) ;
- guiFnt = puGetDefaultLabelFont();
-
-
->Release-Note:
->Audit-Trail:
->Unformatted:
-
diff --git a/games/fgfs-base/patches.tools/Makefile.gpc b/games/fgfs-base/patches.tools/Makefile.gpc
deleted file mode 100644
index 3d926ffa24e5..000000000000
--- a/games/fgfs-base/patches.tools/Makefile.gpc
+++ /dev/null
@@ -1,19 +0,0 @@
-# Unix/Linux makefile for GPC 2.31
-#
-# Riley Rainey (riley.rainey@websimulations.com)
-
-CFLAGS = -O -g
-
-libgpc.a: gpc.o
- rm -f $@
- ar cr $@ $<
- ranlib $@
-
-clean:
- rm -f libgpc.a *.o core *~
-
-install: libgpc.a
- -mkdir -p ${PREFIX}/lib
- -mkdir -p ${PREFIX}/include
- install -c libgpc.a ${PREFIX}/lib/libgpc.a
- install -c gpc.h ${PREFIX}/include/gpc.h
diff --git a/games/fgfs-base/patches.tools/disable-tools b/games/fgfs-base/patches.tools/disable-tools
deleted file mode 100644
index 935b2206ea36..000000000000
--- a/games/fgfs-base/patches.tools/disable-tools
+++ /dev/null
@@ -1,67 +0,0 @@
---- FlightGear-0.6.1/configure.in.orig Sun Jun 27 13:21:03 1999
-+++ FlightGear-0.6.1/configure.in Sun Jun 27 13:21:13 1999
-@@ -244,37 +244,6 @@
-
- AM_CONDITIONAL(HAVE_XWINDOWS, test "x$ac_cv_lib_X11_XCreateWindow" = "xyes" )
-
--dnl Check if Generic Polygon Clipping library is installed
--dnl (from http://www.cs.man.ac.uk/aig/staff/alan/software/)
--AC_CHECK_HEADERS( gpc.h )
--if test "x$ac_cv_header_gpc_h" != "xyes"; then
-- echo
-- echo "You need to have the GPC library installed on your system to build"
-- echo "some of the scenery generation tools, otherwise you won't be able."
-- echo "to create scenery."
-- echo
-- echo "Please see README.gpc for more details."
-- echo
-- echo "(pausing 5 seconds)"
-- sleep 5
-- echo
--fi
--
--dnl Check if Geographic Foundation Classes library is installed
--dnl (from ftp://ftp.flightgear.org/pub/fgfs/Source/)
--AC_CHECK_HEADERS( gfc/gdbf.h )
--if test "x$ac_cv_header_gfc_gdbf_h" != "xyes"; then
-- echo
-- echo "You need to have the GFC library installed on your system to build"
-- echo "some of the scenery generation tools, otherwise, they may fail."
-- echo
-- echo "Please see README.gfc for more details."
-- echo
-- echo "(pausing 5 seconds)"
-- sleep 5
-- echo
--fi
--
- dnl Checks for header files.
- AC_HEADER_STDC
- AC_CHECK_HEADERS( \
---- FlightGear-0.6.1/Makefile.in.orig Sun Jun 27 19:14:27 1999
-+++ FlightGear-0.6.1/Makefile.in Sun Jun 27 19:15:08 1999
-@@ -67,7 +67,7 @@
- base_LIBS = @base_LIBS@
- opengl_LIBS = @opengl_LIBS@
-
--SUBDIRS = Include Lib Simulator Tools Tests
-+SUBDIRS = Include Lib Simulator Tests
-
- EXTRA_DIST = FG-FAQ.v3 README.Unix README.Linux README.MacOS README.Win32 \
- README.Win32-X README.autoconf README.gfc README.gpc README.plib \
-@@ -88,15 +88,9 @@
- all: all-recursive all-am
-
- .SUFFIXES:
--$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
-- cd $(top_srcdir) && $(AUTOMAKE) --gnu --include-deps Makefile
--
- Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
- cd $(top_builddir) \
- && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
--
--$(ACLOCAL_M4): configure.in
-- cd $(srcdir) && $(ACLOCAL)
-
- config.status: $(srcdir)/configure
- $(SHELL) ./config.status --recheck
diff --git a/games/fgfs-base/patches.tools/gfc-patch-aa b/games/fgfs-base/patches.tools/gfc-patch-aa
deleted file mode 100644
index 08b8d4b85dc8..000000000000
--- a/games/fgfs-base/patches.tools/gfc-patch-aa
+++ /dev/null
@@ -1,21 +0,0 @@
---- gfc-0.8.8.1b/utils/src/gmmap.h.orig Wed Feb 17 14:31:03 1999
-+++ gfc-0.8.8.1b/utils/src/gmmap.h Sat Jun 26 21:43:18 1999
-@@ -12,7 +12,18 @@
-
- #include <unistd.h>
-
-+/* the next lines are to define BSD */
-+/* see http://www.freebsd.org/handbook/porting.html for why we do this */
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-+
- #ifdef _LINUX_
-+#include <sys/mman.h>
-+#include <sys/types.h>
-+#endif
-+
-+#ifdef BSD
- #include <sys/mman.h>
- #include <sys/types.h>
- #endif
diff --git a/games/fgfs-base/pkg-comment b/games/fgfs-base/pkg-comment
deleted file mode 100644
index 7a94a4cf8f05..000000000000
--- a/games/fgfs-base/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-The FlightGear flight simulator
diff --git a/games/fgfs-base/pkg-descr b/games/fgfs-base/pkg-descr
deleted file mode 100644
index e49dafe24de4..000000000000
--- a/games/fgfs-base/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-FlightGear is a free, multi-platform civil aviation flight simulator
-package. It features detailed, texture-mapped scenery, keyboard and
-joystick controls, a heads-up display, and optional realistic instrument
-panel. A 3-D accelerator card supported by Mesa is highly recommended (3DFX
-Voodoo/Voodoo2 and nVIDIA Riva TNT are known to work.)
-
-WWW: http://www.flightgear.org/
-
-- Brian Buchanan
-brian@CSUA.Berkeley.EDU
diff --git a/games/fgfs-base/pkg-plist b/games/fgfs-base/pkg-plist
deleted file mode 100644
index dc4fde2a0a38..000000000000
--- a/games/fgfs-base/pkg-plist
+++ /dev/null
@@ -1,178 +0,0 @@
-bin/runfgfs
-FlightGear/bin/showme
-FlightGear/bin/deminfo
-FlightGear/bin/demchop
-FlightGear/bin/shape-decode
-FlightGear/bin/genapts
-FlightGear/bin/raw2ascii
-FlightGear/bin/fgfs
-FlightGear/bin/fgfs-tools-server
-FlightGear/bin/fgfs-tools-client
-FlightGear/bin/fgfs-master
-FlightGear/bin/fgfs-construct
-FlightGear/bin/test-mktime
-FlightGear/bin/gl-info
-FlightGear/bin/est-epsilon
-FlightGear/AUTHORS
-FlightGear/ChangeLog
-FlightGear/COPYING
-FlightGear/NEWS
-FlightGear/README
-FlightGear/README.Linux
-FlightGear/README.MacOS
-FlightGear/README.Unix
-FlightGear/README.Win32
-FlightGear/README.anoncvs
-FlightGear/README.autoconf
-FlightGear/README.gpc
-FlightGear/README.running
-FlightGear/Thanks
-FlightGear/materials
-FlightGear/runfgfs.bat
-FlightGear/Airports/apt_simple.gz
-FlightGear/Airports/default.apt.gz
-FlightGear/Astro/planets.gz
-FlightGear/Astro/stars
-FlightGear/Engine/XLR99.dat
-FlightGear/Fonts/README
-FlightGear/Fonts/charter.txf
-FlightGear/Fonts/courier-bold.txf
-FlightGear/Fonts/courier_medium.txf
-FlightGear/Fonts/curlfont.txf
-FlightGear/Fonts/default.txf
-FlightGear/Fonts/haeberli.txf
-FlightGear/Fonts/helvetica_bold.txf
-FlightGear/Fonts/helvetica_medium.txf
-FlightGear/Fonts/lucida.txf
-FlightGear/Fonts/lucidabright_bold.txf
-FlightGear/Fonts/schoolbook_bold.txf
-FlightGear/Fonts/schoolbook_medium.txf
-FlightGear/Fonts/sorority.txf
-FlightGear/Fonts/symbol.txf
-FlightGear/Fonts/times_bold.txf
-FlightGear/Fonts/times_medium.txf
-FlightGear/Fonts/typewriter.txf
-FlightGear/Lighting/ambient
-FlightGear/Lighting/ambient.old
-FlightGear/Lighting/ambient.orig
-FlightGear/Lighting/diffuse
-FlightGear/Lighting/diffuse.orig
-FlightGear/Lighting/sky
-FlightGear/Lighting/sky.old
-FlightGear/Sounds/intro.mp3
-FlightGear/Sounds/thunder.wav
-FlightGear/Sounds/wasp.wav
-FlightGear/Textures/FG-Textures.txt
-FlightGear/Textures/Fullone.rgb
-FlightGear/Textures/Splash1.rgb.gz
-FlightGear/Textures/Splash2.rgb.gz
-FlightGear/Textures/Splash3.rgb.gz
-FlightGear/Textures/Splash4.rgb.gz
-FlightGear/Textures/asphalt.rgb.gz
-FlightGear/Textures/austral1.rgb.gz
-FlightGear/Textures/canyon-pink.rgb.gz
-FlightGear/Textures/canyon-sand.rgb.gz
-FlightGear/Textures/concrete.rgb.gz
-FlightGear/Textures/desert.rgb
-FlightGear/Textures/desert1.rgb
-FlightGear/Textures/forest1.rgb.gz
-FlightGear/Textures/forest2.rgb.gz
-FlightGear/Textures/gauges.rgb
-FlightGear/Textures/gauges2.rgb
-FlightGear/Textures/glacier.rgb.gz
-FlightGear/Textures/grass.rgb.gz
-FlightGear/Textures/grs-bv.rgb.gz
-FlightGear/Textures/hori.rgb
-FlightGear/Textures/ice-wint.rgb.gz
-FlightGear/Textures/marsh1.rgb.gz
-FlightGear/Textures/marsh2.rgb.gz
-FlightGear/Textures/moon.rgb
-FlightGear/Textures/panel_texture.rgb
-FlightGear/Textures/resgrid.rgb.gz
-FlightGear/Textures/rocks-desert.rgb.gz
-FlightGear/Textures/rocks-grass.rgb.gz
-FlightGear/Textures/unknown.rgb.gz
-FlightGear/Textures/urban.rgb.gz
-FlightGear/Textures/water.rgb.gz
-FlightGear/Aircraft/X15/Reset00
-FlightGear/Aircraft/X15/X15.dat
-FlightGear/Aircraft/X15/CDRAG/A
-FlightGear/Aircraft/X15/CDRAG/A0
-FlightGear/Aircraft/X15/CDRAG/DE
-FlightGear/Aircraft/X15/CDRAG/M
-FlightGear/Aircraft/X15/CLIFT/A
-FlightGear/Aircraft/X15/CLIFT/A0
-FlightGear/Aircraft/X15/CLIFT/ADT
-FlightGear/Aircraft/X15/CLIFT/M
-FlightGear/Aircraft/X15/CLIFT/de
-FlightGear/Aircraft/X15/CPITCH/A
-FlightGear/Aircraft/X15/CPITCH/A0
-FlightGear/Aircraft/X15/CPITCH/ADT
-FlightGear/Aircraft/X15/CPITCH/De
-FlightGear/Aircraft/X15/CPITCH/M
-FlightGear/Aircraft/X15/CPITCH/Q
-FlightGear/Aircraft/X15/CROLL/B
-FlightGear/Aircraft/X15/CROLL/DA
-FlightGear/Aircraft/X15/CROLL/DR
-FlightGear/Aircraft/X15/CROLL/P
-FlightGear/Aircraft/X15/CROLL/R
-FlightGear/Aircraft/X15/CSIDE/B
-FlightGear/Aircraft/X15/CSIDE/DA
-FlightGear/Aircraft/X15/CSIDE/DR
-FlightGear/Aircraft/X15/CSIDE/R
-FlightGear/Aircraft/X15/CYAW/A
-FlightGear/Aircraft/X15/CYAW/A0
-FlightGear/Aircraft/X15/CYAW/DE
-FlightGear/Aircraft/X15/CYAW/M
-FlightGear/Scenery/w120n30/w111n33/1138368.gz
-FlightGear/Scenery/w120n30/w111n33/1138369.gz
-FlightGear/Scenery/w120n30/w111n33/1138370.gz
-FlightGear/Scenery/w120n30/w111n33/1138371.gz
-FlightGear/Scenery/w120n30/w111n33/1138376.gz
-FlightGear/Scenery/w120n30/w111n33/1138377.gz
-FlightGear/Scenery/w120n30/w111n33/1138378.gz
-FlightGear/Scenery/w120n30/w111n33/1138379.gz
-FlightGear/Scenery/w120n30/w111n33/1138384.gz
-FlightGear/Scenery/w120n30/w111n33/1138385.gz
-FlightGear/Scenery/w120n30/w111n33/1138386.gz
-FlightGear/Scenery/w120n30/w111n33/1138387.gz
-FlightGear/Scenery/w120n30/w111n33/1138392.gz
-FlightGear/Scenery/w120n30/w111n33/1138393.gz
-FlightGear/Scenery/w120n30/w111n33/1138394.gz
-FlightGear/Scenery/w120n30/w111n33/1138395.gz
-FlightGear/Scenery/w120n30/w111n33/1138400.gz
-FlightGear/Scenery/w120n30/w111n33/1138401.gz
-FlightGear/Scenery/w120n30/w111n33/1138402.gz
-FlightGear/Scenery/w120n30/w111n33/1138403.gz
-FlightGear/Scenery/w120n30/w111n33/1138408.gz
-FlightGear/Scenery/w120n30/w111n33/1138409.gz
-FlightGear/Scenery/w120n30/w111n33/1138410.gz
-FlightGear/Scenery/w120n30/w111n33/1138411.gz
-FlightGear/Scenery/w120n30/w111n33/1138416.gz
-FlightGear/Scenery/w120n30/w111n33/1138417.gz
-FlightGear/Scenery/w120n30/w111n33/1138418.gz
-FlightGear/Scenery/w120n30/w111n33/1138419.gz
-FlightGear/Scenery/w120n30/w111n33/1138424.gz
-FlightGear/Scenery/w120n30/w111n33/1138425.gz
-FlightGear/Scenery/w120n30/w111n33/1138426.gz
-FlightGear/Scenery/w120n30/w111n33/1138427.gz
-@dirrm FlightGear/Aircraft/X15/CDRAG
-@dirrm FlightGear/Aircraft/X15/CLIFT
-@dirrm FlightGear/Aircraft/X15/CPITCH
-@dirrm FlightGear/Aircraft/X15/CROLL
-@dirrm FlightGear/Aircraft/X15/CSIDE
-@dirrm FlightGear/Aircraft/X15/CYAW
-@dirrm FlightGear/Aircraft/X15
-@dirrm FlightGear/Aircraft
-@dirrm FlightGear/Airports
-@dirrm FlightGear/Astro
-@dirrm FlightGear/Engine
-@dirrm FlightGear/Fonts
-@dirrm FlightGear/Lighting
-@dirrm FlightGear/Scenery/w120n30/w111n33
-@dirrm FlightGear/Scenery/w120n30
-@dirrm FlightGear/Scenery
-@dirrm FlightGear/Sounds
-@dirrm FlightGear/Textures
-@dirrm FlightGear/bin
-@dirrm FlightGear
diff --git a/games/fgfs-base/pkg-plist.notools b/games/fgfs-base/pkg-plist.notools
deleted file mode 100644
index 5a90c6bf8d93..000000000000
--- a/games/fgfs-base/pkg-plist.notools
+++ /dev/null
@@ -1,168 +0,0 @@
-bin/runfgfs
-FlightGear/bin/est-epsilon
-FlightGear/bin/fgfs
-FlightGear/bin/gl-info
-FlightGear/bin/test-mktime
-@dirrm FlightGear/bin
-FlightGear/AUTHORS
-FlightGear/ChangeLog
-FlightGear/COPYING
-FlightGear/NEWS
-FlightGear/README
-FlightGear/README.Linux
-FlightGear/README.MacOS
-FlightGear/README.Unix
-FlightGear/README.Win32
-FlightGear/README.anoncvs
-FlightGear/README.autoconf
-FlightGear/README.gpc
-FlightGear/README.running
-FlightGear/Thanks
-FlightGear/materials
-FlightGear/runfgfs.bat
-FlightGear/Airports/apt_simple.gz
-FlightGear/Airports/default.apt.gz
-FlightGear/Astro/planets.gz
-FlightGear/Astro/stars
-FlightGear/Engine/XLR99.dat
-FlightGear/Fonts/README
-FlightGear/Fonts/charter.txf
-FlightGear/Fonts/courier-bold.txf
-FlightGear/Fonts/courier_medium.txf
-FlightGear/Fonts/curlfont.txf
-FlightGear/Fonts/default.txf
-FlightGear/Fonts/haeberli.txf
-FlightGear/Fonts/helvetica_bold.txf
-FlightGear/Fonts/helvetica_medium.txf
-FlightGear/Fonts/lucida.txf
-FlightGear/Fonts/lucidabright_bold.txf
-FlightGear/Fonts/schoolbook_bold.txf
-FlightGear/Fonts/schoolbook_medium.txf
-FlightGear/Fonts/sorority.txf
-FlightGear/Fonts/symbol.txf
-FlightGear/Fonts/times_bold.txf
-FlightGear/Fonts/times_medium.txf
-FlightGear/Fonts/typewriter.txf
-FlightGear/Lighting/ambient
-FlightGear/Lighting/ambient.old
-FlightGear/Lighting/ambient.orig
-FlightGear/Lighting/diffuse
-FlightGear/Lighting/diffuse.orig
-FlightGear/Lighting/sky
-FlightGear/Lighting/sky.old
-FlightGear/Sounds/intro.mp3
-FlightGear/Sounds/thunder.wav
-FlightGear/Sounds/wasp.wav
-FlightGear/Textures/FG-Textures.txt
-FlightGear/Textures/Fullone.rgb
-FlightGear/Textures/Splash1.rgb.gz
-FlightGear/Textures/Splash2.rgb.gz
-FlightGear/Textures/Splash3.rgb.gz
-FlightGear/Textures/Splash4.rgb.gz
-FlightGear/Textures/asphalt.rgb.gz
-FlightGear/Textures/austral1.rgb.gz
-FlightGear/Textures/canyon-pink.rgb.gz
-FlightGear/Textures/canyon-sand.rgb.gz
-FlightGear/Textures/concrete.rgb.gz
-FlightGear/Textures/desert.rgb
-FlightGear/Textures/desert1.rgb
-FlightGear/Textures/forest1.rgb.gz
-FlightGear/Textures/forest2.rgb.gz
-FlightGear/Textures/gauges.rgb
-FlightGear/Textures/gauges2.rgb
-FlightGear/Textures/glacier.rgb.gz
-FlightGear/Textures/grass.rgb.gz
-FlightGear/Textures/grs-bv.rgb.gz
-FlightGear/Textures/hori.rgb
-FlightGear/Textures/ice-wint.rgb.gz
-FlightGear/Textures/marsh1.rgb.gz
-FlightGear/Textures/marsh2.rgb.gz
-FlightGear/Textures/moon.rgb
-FlightGear/Textures/panel_texture.rgb
-FlightGear/Textures/resgrid.rgb.gz
-FlightGear/Textures/rocks-desert.rgb.gz
-FlightGear/Textures/rocks-grass.rgb.gz
-FlightGear/Textures/unknown.rgb.gz
-FlightGear/Textures/urban.rgb.gz
-FlightGear/Textures/water.rgb.gz
-FlightGear/Aircraft/X15/Reset00
-FlightGear/Aircraft/X15/X15.dat
-FlightGear/Aircraft/X15/CDRAG/A
-FlightGear/Aircraft/X15/CDRAG/A0
-FlightGear/Aircraft/X15/CDRAG/DE
-FlightGear/Aircraft/X15/CDRAG/M
-FlightGear/Aircraft/X15/CLIFT/A
-FlightGear/Aircraft/X15/CLIFT/A0
-FlightGear/Aircraft/X15/CLIFT/ADT
-FlightGear/Aircraft/X15/CLIFT/M
-FlightGear/Aircraft/X15/CLIFT/de
-FlightGear/Aircraft/X15/CPITCH/A
-FlightGear/Aircraft/X15/CPITCH/A0
-FlightGear/Aircraft/X15/CPITCH/ADT
-FlightGear/Aircraft/X15/CPITCH/De
-FlightGear/Aircraft/X15/CPITCH/M
-FlightGear/Aircraft/X15/CPITCH/Q
-FlightGear/Aircraft/X15/CROLL/B
-FlightGear/Aircraft/X15/CROLL/DA
-FlightGear/Aircraft/X15/CROLL/DR
-FlightGear/Aircraft/X15/CROLL/P
-FlightGear/Aircraft/X15/CROLL/R
-FlightGear/Aircraft/X15/CSIDE/B
-FlightGear/Aircraft/X15/CSIDE/DA
-FlightGear/Aircraft/X15/CSIDE/DR
-FlightGear/Aircraft/X15/CSIDE/R
-FlightGear/Aircraft/X15/CYAW/A
-FlightGear/Aircraft/X15/CYAW/A0
-FlightGear/Aircraft/X15/CYAW/DE
-FlightGear/Aircraft/X15/CYAW/M
-FlightGear/Scenery/w120n30/w111n33/1138368.gz
-FlightGear/Scenery/w120n30/w111n33/1138369.gz
-FlightGear/Scenery/w120n30/w111n33/1138370.gz
-FlightGear/Scenery/w120n30/w111n33/1138371.gz
-FlightGear/Scenery/w120n30/w111n33/1138376.gz
-FlightGear/Scenery/w120n30/w111n33/1138377.gz
-FlightGear/Scenery/w120n30/w111n33/1138378.gz
-FlightGear/Scenery/w120n30/w111n33/1138379.gz
-FlightGear/Scenery/w120n30/w111n33/1138384.gz
-FlightGear/Scenery/w120n30/w111n33/1138385.gz
-FlightGear/Scenery/w120n30/w111n33/1138386.gz
-FlightGear/Scenery/w120n30/w111n33/1138387.gz
-FlightGear/Scenery/w120n30/w111n33/1138392.gz
-FlightGear/Scenery/w120n30/w111n33/1138393.gz
-FlightGear/Scenery/w120n30/w111n33/1138394.gz
-FlightGear/Scenery/w120n30/w111n33/1138395.gz
-FlightGear/Scenery/w120n30/w111n33/1138400.gz
-FlightGear/Scenery/w120n30/w111n33/1138401.gz
-FlightGear/Scenery/w120n30/w111n33/1138402.gz
-FlightGear/Scenery/w120n30/w111n33/1138403.gz
-FlightGear/Scenery/w120n30/w111n33/1138408.gz
-FlightGear/Scenery/w120n30/w111n33/1138409.gz
-FlightGear/Scenery/w120n30/w111n33/1138410.gz
-FlightGear/Scenery/w120n30/w111n33/1138411.gz
-FlightGear/Scenery/w120n30/w111n33/1138416.gz
-FlightGear/Scenery/w120n30/w111n33/1138417.gz
-FlightGear/Scenery/w120n30/w111n33/1138418.gz
-FlightGear/Scenery/w120n30/w111n33/1138419.gz
-FlightGear/Scenery/w120n30/w111n33/1138424.gz
-FlightGear/Scenery/w120n30/w111n33/1138425.gz
-FlightGear/Scenery/w120n30/w111n33/1138426.gz
-FlightGear/Scenery/w120n30/w111n33/1138427.gz
-@dirrm FlightGear/Aircraft/X15/CDRAG
-@dirrm FlightGear/Aircraft/X15/CLIFT
-@dirrm FlightGear/Aircraft/X15/CPITCH
-@dirrm FlightGear/Aircraft/X15/CROLL
-@dirrm FlightGear/Aircraft/X15/CSIDE
-@dirrm FlightGear/Aircraft/X15/CYAW
-@dirrm FlightGear/Aircraft/X15
-@dirrm FlightGear/Aircraft
-@dirrm FlightGear/Airports
-@dirrm FlightGear/Astro
-@dirrm FlightGear/Engine
-@dirrm FlightGear/Fonts
-@dirrm FlightGear/Lighting
-@dirrm FlightGear/Scenery/w120n30/w111n33
-@dirrm FlightGear/Scenery/w120n30
-@dirrm FlightGear/Scenery
-@dirrm FlightGear/Sounds
-@dirrm FlightGear/Textures
-@dirrm FlightGear