aboutsummaryrefslogtreecommitdiff
path: root/games/fheroes2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/fheroes2/Makefile')
-rw-r--r--games/fheroes2/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/games/fheroes2/Makefile b/games/fheroes2/Makefile
index f8b7d6967348..04ee67fc5219 100644
--- a/games/fheroes2/Makefile
+++ b/games/fheroes2/Makefile
@@ -1,29 +1,21 @@
PORTNAME= fheroes2
-PORTVERSION= 0.9.7
+PORTVERSION= 1.0.13
CATEGORIES= games
MAINTAINER= pkubaj@FreeBSD.org
COMMENT= Free implementation of Heroes of Might and Magic II engine
+WWW= https://ihhub.github.io/fheroes2/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libpng.so:graphics/png
+RUN_DEPENDS= timidity:audio/timidity
-USES= cmake gettext-tools iconv localbase:ldflags pkgconfig sdl \
- shebangfix
+USES= cmake sdl
USE_GITHUB= yes
GH_ACCOUNT= ihhub
-USE_SDL= image2 mixer2 sdl2 ttf2
-SHEBANG_FILES= script/demo/demo_unix.sh
+USE_SDL= mixer2 sdl2
OPTIONS_DEFINE= DOCS
-PLIST_FILES= bin/${PORTNAME} \
- ${DATADIR}/files/data/resurrection.h2d
-PORTDOCS= LICENSE \
- README.txt \
- changelog.txt \
- demo/demo_unix.sh
-
.include <bsd.port.mk>