aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/flightgear/Makefile')
-rw-r--r--games/flightgear/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index bafb9d97211b..e14d1c011467 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -57,4 +57,10 @@ post-patch:
# Avoid conflict with C++20 <version> - used version file is flightgear-version
@${RM} ${WRKSRC}/version
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == "clang" && ${COMPILER_VERSION} >= 150
+LDFLAGS_i386+= -Wl,--no-check-dynamic-relocations
+.endif
+
+.include <bsd.port.post.mk>