aboutsummaryrefslogtreecommitdiff
path: root/games/gnome-sudoku/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gnome-sudoku/Makefile')
-rw-r--r--games/gnome-sudoku/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/games/gnome-sudoku/Makefile b/games/gnome-sudoku/Makefile
index c646cad87dad..885ba0e52e0c 100644
--- a/games/gnome-sudoku/Makefile
+++ b/games/gnome-sudoku/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gnome-sudoku
-PORTVERSION= 3.18.2
+PORTVERSION= 3.24.0
CATEGORIES= games gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -10,19 +10,23 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Sudoku game for gnome
-BUILD_DEPENDS= itstool:textproc/itstool
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= itstool:textproc/itstool \
+ appstream-util:devel/appstream-glib \
+ vala:lang/vala
LIB_DEPENDS= libgee-0.8.so:devel/libgee \
libqqwing.so:games/qqwing \
libjson-glib-1.0.so:devel/json-glib
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome pathfix pkgconfig python:3 shebangfix tar:xz
-USE_GNOME= gtk30 intlhack libxml2:build py3gobject3
+USES= gettext gmake gnome localbase pathfix \
+ pkgconfig python:3.3+ shebangfix tar:xz
+USE_GNOME= cairo gtk30 intlhack libxml2:build py3gobject3
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.gnome.sudoku.gschema.xml