aboutsummaryrefslogtreecommitdiff
path: root/games/minetest/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/minetest/Makefile')
-rw-r--r--games/minetest/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/games/minetest/Makefile b/games/minetest/Makefile
index a4a2aae35368..da5b41a3c88c 100644
--- a/games/minetest/Makefile
+++ b/games/minetest/Makefile
@@ -106,10 +106,12 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/cmake/Modules/*.cmake
-do-test-CLIENT-on:
+do-test-TEST-on:
+.if ${PORT_OPTIONS:MCLIENT}
cd ${WRKDIR} && ${SETENV} ${TEST_ENV} ${STAGEDIR}${PREFIX}/bin/minetest --run-unittests
-
-do-test-SERVER-on:
+.endif
+.if ${PORT_OPTIONS:MSERVER}
cd ${WRKDIR} && ${SETENV} ${TEST_ENV} ${STAGEDIR}${PREFIX}/bin/minetestserver --run-unittests
+.endif
.include <bsd.port.mk>